Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The title say's it all, qMail is taking at least 30-60 seconds to fire off an email, that is if the client software doesn't time out first!

I've tried Outlook, emClient, RoundCube Webmail and an Android Mail Client.... same results on each.

Looking at the maillog there seems to be hundreds of new entries every second.

Here is a snippit:

    Dec 14 14:51:21 tgdb qmail: 1355485881.151176 starting delivery 211: msg 210515326 to local 1-postmaster@thegamesd$
    Dec 14 14:51:21 tgdb qmail: 1355485881.151208 status: local 2/10 remote 8/20
    Dec 14 14:51:21 tgdb qmail: 1355485881.151717 starting delivery 212: msg 210515274 to local 1-root@thegamesdb.net
    Dec 14 14:51:21 tgdb qmail: 1355485881.151739 status: local 3/10 remote 8/20
    Dec 14 14:51:21 tgdb qmail-local-handlers[12139]: Handlers Filter before-local for qmail started ...
    Dec 14 14:51:21 tgdb qmail-local-handlers[12140]: Handlers Filter before-local for qmail started ...
    Dec 14 14:51:21 tgdb qmail-local-handlers[12140]: from=
    Dec 14 14:51:21 tgdb qmail-local-handlers[12140]: to=root@thegamesdb.net
    Dec 14 14:51:21 tgdb qmail-local-handlers[12140]: mailbox: /var/qmail/mailnames/thegamesdb.net
    Dec 14 14:51:21 tgdb qmail-local-handlers[12139]: from=#@[]
    Dec 14 14:51:21 tgdb qmail-local-handlers[12139]: to=postmaster@thegamesdb.net
    Dec 14 14:51:21 tgdb qmail-local-handlers[12139]: mailbox: /var/qmail/mailnames/thegamesdb.net
    Dec 14 14:51:21 tgdb qmail-local-handlers[12140]: Unable to get sender domain by sender mailname
    Dec 14 14:51:21 tgdb qmail: 1355485881.183685 starting delivery 213: msg 210513508 to local 1-postmaster@thegamesd$
    Dec 14 14:51:21 tgdb qmail: 1355485881.183726 status: local 4/10 remote 8/20
    Dec 14 14:51:21 tgdb qmail: 1355485881.183736 delivery 210: deferral: ./Maildir:_No_such_file_or_directory/
    Dec 14 14:51:21 tgdb qmail: 1355485881.183745 status: local 3/10 remote 8/20
    Dec 14 14:51:21 tgdb qmail: 1355485881.183755 delivery 212: failure: ./Maildir:_No_such_file_or_directory/I'm_not_$
    Dec 14 14:51:21 tgdb qmail: 1355485881.183764 status: local 2/10 remote 8/20
    Dec 14 14:51:21 tgdb qmail-queue-handlers[12148]: Handlers Filter before-queue for qmail started ...
    Dec 14 14:51:21 tgdb qmail-local-handlers[12149]: Handlers Filter before-local for qmail started ...
    Dec 14 14:51:21 tgdb qmail-queue-handlers[12148]: from=#@[]
    Dec 14 14:51:21 tgdb qmail-queue-handlers[12148]: to=postmaster@tgdb.(none)
    Dec 14 14:51:21 tgdb qmail-local-handlers[12149]: from=#@[]
    Dec 14 14:51:21 tgdb qmail-local-handlers[12149]: to=postmaster@thegamesdb.net
    Dec 14 14:51:21 tgdb qmail-local-handlers[12149]: mailbox: /var/qmail/mailnames/thegamesdb.net
    Dec 14 14:51:21 tgdb qmail-queue-handlers[12148]: starter: submitter[12150] exited normally
    Dec 14 14:51:21 tgdb qmail: 1355485881.226147 bounce msg 210515274 qp 12148
    Dec 14 14:51:21 tgdb qmail: 1355485881.227155 end msg 210515274
    Dec 14 14:51:21 tgdb qmail: 1355485881.227421 delivery 211: failure: ./Maildir:_No_such_file_or_directory/I'm_not_$
    Dec 14 14:51:21 tgdb qmail: 1355485881.229095 status: local 1/10 remote 8/20
    Dec 14 14:51:21 tgdb qmail: 1355485881.246970 starting delivery 214: msg 210516149 to local 1-postmaster@thegamesd$
    Dec 14 14:51:21 tgdb qmail: 1355485881.247013 status: local 2/10 remote 8/20
    Dec 14 14:51:21 tgdb qmail: 1355485881.247025 triple bounce: discarding bounce/210515326
    Dec 14 14:51:21 tgdb qmail: 1355485881.247183 end msg 210515326
    Dec 14 14:51:21 tgdb qmail: 1355485881.247552 delivery 213: deferral: ./Maildir:_No_such_file_or_directory/
    Dec 14 14:51:21 tgdb qmail: 1355485881.247573 status: local 1/10 remote 8/20
    Dec 14 14:51:21 tgdb qmail-local-handlers[12158]: Handlers Filter before-local for qmail started ...
    Dec 14 14:51:21 tgdb qmail-local-handlers[12158]: from=#@[]
    Dec 14 14:51:21 tgdb qmail-local-handlers[12158]: to=postmaster@thegamesdb.net
    Dec 14 14:51:21 tgdb qmail-local-handlers[12158]: mailbox: /var/qmail/mailnames/thegamesdb.net
    Dec 14 14:51:21 tgdb qmail: 1355485881.281957 starting delivery 215: msg 210514740 to local 1-postmaster@thegamesd$
    Dec 14 14:51:21 tgdb qmail: 1355485881.282001 status: local 2/10 remote 8/20
    Dec 14 14:51:21 tgdb qmail: 1355485881.282013 delivery 214: deferral: ./Maildir:_No_such_file_or_directory/
    Dec 14 14:51:21 tgdb qmail: 1355485881.282022 status: local 1/10 remote 8/20

Does anyone have any suggestions?

share|improve this question
2  
You said "..if the client software doesn't time out...", so does that mean that the delay happens at some point during the transaction between the client and the server? Have you tried connecting to port 25 via telnet to manually send a message and see at what point there's a delay? BTW, the log section you included doesn't show a delay, since all lines have the same timestamp. –  1.618 Dec 14 '12 at 13:06
    
What are you trying to send, as in does it have an attachment? Have you used wireshark or another packets sniffer to see what, if anything, is happening between the client and server? –  Bart Silverstrim Dec 14 '12 at 13:24
    
I also see that your logs are throwing what looks like deferral messages because it can't deliver the message you're trying to send... –  Bart Silverstrim Dec 14 '12 at 13:25

1 Answer 1

up vote 0 down vote accepted

it seems that it's taking at least 20 seconds for the SMTP server to respond to connection requests.

I ran "telnet mail.penoval.co.uk 25", and it took roughly 30 seconds for me to get the welcome message back.

Any ideas on what could be causing this, HTTP traffic isn't suffering from the same delay :P

Edit: Looking into this it seems that qmail can be slow at accepting connections if it is trying to do Reverse DNS lookups and if started by tcpserver as can be seen at this page: http://www.lifewithqmail.org/lwq.html#smtp-slow

Looking into it to see if this matches my usage.

Edit 2: OK, I eventually found the solution to this several months later... It seems Reverse DNS had been incorrectly configured for my IP in my VPS providers control panel, even though I had bound the correct domain and IP together in the control panel, it failed to action the changes. This was fixed by contacting my VPS provider and requesting the change be actioned.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.