Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently did a clean install of Mountain Lion on my Mac Mini Server.

I installed version 3.0.18 using a gem according to the directions on with no errors that I could see.

rvmsudo gem install passenger-enterprise-server-3.0.18.gem
rvmsudo passenger-install-apache2-module

Here are my entries in /etc/apache2/httpd.conf with my username masked:

LoadModule passenger_module /Users/username/.rvm/gems/ruby-1.9.3-p327/gems/passenger-enterprise-server-3.0.18/ext/apache2/
PassengerRoot /Users/username/.rvm/gems/ruby-1.9.3-p327/gems/passenger-enterprise-server-3.0.18
PassengerRuby /Users/username/.rvm/wrappers/ruby-1.9.3-p327/ruby

I uncommented out the following statement:

Include /private/etc/apache2/extra/httpd-vhosts.conf

Here is a sample virtual host entry. I have three of them in the file.

<VirtualHost *:80>
  PassengerAppRoot /Users/username/Sites/myfolder/
  DocumentRoot /Users/username/Sites/myfolder/public
  <Directory /Users/username/Sites/myfolder/public>
     Allow from all
     AllowOverride all
     Options -MultiViews

I have restarted Apache several times. Here is information from my server:

[~]$ ps -ef | grep Passenger
  501 18804   303   0 12:39PM ttys000    0:00.00 grep Passenger
[~]$ rvmsudo passenger-status
**ERROR: Phusion Passenger doesn't seem to be running.**
[~]$ rvmsudo passenger-config --version  

I have tried doing online searches on this. I was surprised that there was not all that much on this specific error even though from my understanding Passenger has been around for a few years. I have posted this issue on the Phusion Passenger Google Groups but have not heard anything.

Any help would be appreciated, the sooner the better LOL. Seriously I need to have one of my three websites up by tomorrow evening. This is the only issue stopping that from happening. Thanks again.

share|improve this question
Have you tried looking at Apache's error log? – Travis Pessetto Dec 14 '12 at 20:57
I forgot to include that I checked the Apache error logs. I checked the access and error logs searching for passenger but did not find the word there. This is when I decided to post this question. – LightBe Corp Dec 15 '12 at 0:23

I continued searching but still did not find anything on this error for people using Mountain Lion. After several days of utter frustration I decided to contact Phusion since I had recently purchased one of the support packages. The support I received was more than worth what I paid for it. I had come to the conclusion that something must have changed somewhere between Lion and Mountain Lion but did not know where to look.

The setup I tried after upgrading to Mountain Lion (OS X Server) worked perfectly when I used Passenger with Lion Server. After a lot of extensive checking the support person decided to try making the changes I made in /etc/apache2/httpd.conf in the config file for the Web Service located in /Library/Server/Web/Config/apache2/httpd_server_app.conf. All my Rails applications loaded perfectly. Apparently the other config file is either ignored or something. When the support person led me in trying things in /etc/apache2/httpd.conf and checking logs nothing appeared in them. This is when he decided to try updating the Web Service config file.

Note: I have to give a shout out to the support team at Phusion. When I tell you that they searched for a needle in a haystack I am not exaggerating. I created several files with notes from their support that I hope to never have to use again. They were excellent and very easy to work with.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.