Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running a CentOS VM on my desktop that I use for development testing when coding in python. At my school I have a dedicated IP setup for the VM and my desktop so I never seem to have an issue ssh'ing from desktop into VM. I am now at home for winter break and cannot seem to SSH into the VM using the local ip address behind my router, the external IP with port 22 forwarded to my VM, or anything. Strangely enough I can ssh into my production server and then fromt here ssh into the VM, but not from my desktop to the VM directly

What should I do to get this to work? Thanks

share|improve this question
add comment

closed as off topic by EEAA, Michael Hampton, mdpc, Magellan, Ward Dec 16 '12 at 8:39

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 2 down vote accepted

Check VM setting

  1. Check your VM can ping any public IPs, such as 8.8.8.8
  2. Check your VM can your home router external/public IP (make sure you enable ping response on your router)

Check Rrouter setting

  1. Check your VM IP is correctly setup on your port forwarding rules

Check Host machine setting

  1. Check your desktop firewall, try turn off completely for testing purposes. It is possible related to public/work settings if it is a windows firewall, which allow all LAN connection but refuse WAN connection.

On hosting machine, in file explorer, go to

Control Panel\All Control Panel Items\Windows Firewall\Allowed apps

The above path is for windows 8, other windows version may differ slightly.

Look for application name (eg. Virtual Box is "Oracle VM VirtualBox"). There are 3 check boxes for the application, check mark them all, restart your app and it should work.

For VMware Player, you may have to add vmplayer.exe into the list. Then check mark Public, the other 2 boxes should be checked already when you add it.

share|improve this answer
    
Thanks, the VMWare connections were unidentified (aka public) so I had to take some steps to make them hidden from the firewall settings in order for me to access. For anyone needing help I used this article: kb.vmware.com/selfservice/microsites/… Specifically "Redefine the VMware virtual NICs as endpoint devices" is the part that I did –  MasterGberry Dec 15 '12 at 20:29
    
Sigh, this worked for like one hour and then broke lol. The idea behind this solution is still right, but my comment doesn't seem to fix it for me...maybe others will have better luck –  MasterGberry Dec 15 '12 at 22:22
    
To narrow down the situation, try turn of HOST firewall for testing. I may have solution but will have to wait till very late tonight. –  John Siu Dec 15 '12 at 22:53
    
I'm just using windows firewall, and from my experience in the past turning off the firewall doesn't open up all of the ports and ips, rather closes everything down with it? –  MasterGberry Dec 15 '12 at 22:56
    
Anyways I will await your solution tonight then. As some more information for debugging this issue I am able to ping anyone on the network from the virtual machine or my desktop and vice versa, but I am not able to have the virtual machine and the actual host communicate for some reason. –  MasterGberry Dec 15 '12 at 23:17
show 1 more comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.