Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.


I Know this is a Common topic here but I'm still confused.
I have a Windows Server 2003 DHCP/App Server Machine with DNS configured. The Clients are Lubuntu 12.04 Systems.
I want to host my PHP Application on the Intranet by a domain name. But Im not sure how to do that. I know about Hosts File thing but I cant Daily change the Host File as the systems might change.
My Server's Static IP is 10.12.16.1 subnet 255.0.0.0 DNS name: gn-lrr.intranet
When I put my SERVER NAME (i.e gn-lrr-server) name on the address bar of FF the Site opens, will it work on other pcs the same way?.

Please Give a detailed instructions. Regards!

share|improve this question

1 Answer 1

The hostname of your server, gn-lrr-server is a local name in your network. It won't work from outside of your network without a VPN connection. But as long as the application is only used internally, this hostname will work on all machines that use your Windows Server 2003 as their DNS server (which they likely all do). If you have machines in your network that use another DNS server than your own server, you should alter their hosts file by adding this line:

10.12.16.1    gn-lrr-server

That way, they will resolve that name to the given IP address, no matter what DNS server they use.

share|improve this answer
    
thanks... they use my dns server only so it will work normally right? That is no extra settings required? –  DragoTech.Innovations Dec 16 '12 at 14:23
    
plus how can i make gn-librr-server/lms to lms.gn-librr-server via DNS? –  DragoTech.Innovations Dec 16 '12 at 14:29
    
@DragoTech.Innovations Yes, as long as they use your DNS, the name will always resolve to the correct IP address. The subdomain must be added in your DNS configuration, along with the subdomain configuration on your web server (probably IIS). Then under the lms directory of your main domain, add a file that redirects them to your subdomain. It's quite a few steps, so you might want to add this as a new question if the above is not sufficient. –  Oldskool Dec 16 '12 at 16:04
    
Thank you... Last Night the client PCs were not resolving gn-lrr-server to the desired page... instead they started a google search... why did that occur? Sorry for any typos.. my hands are freezing... ;) –  DragoTech.Innovations Dec 17 '12 at 7:28
    
They specifically need to use either a http:// prefix or a .intranet suffix to avoid starting a search. The http prefix should work best. A bookmark might also help :) –  Oldskool Dec 17 '12 at 10:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.