Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Okay let me get straight to the point, I am a complete noob, and have never done stuff like this at all, I have read tutorial after tuorial but I cant get anything to work. When I tried to install the rpm file I got this error

rpm -Uvh ftp://ftp.pbone.net/mirror/rpms.famillecollet.com/enterprise/6/test/x86_64/php-mysqlnd-5.4.9-1.el6.remi.x86_64.rpm
Retrieving ftp://ftp.pbone.net/mirror/rpms.famillecollet.com/enterprise/6/test/x86_64/php-mysqlnd-5.4.9-1.el6.remi.x86_64.rpm
warning: /var/tmp/rpm-tmp.ez4vvd: Header V3 DSA/SHA1 Signature, key ID 00f97f56: NOKEY
error: Failed dependencies:
        php-pdo(x86-64) = 5.4.9-1.el6.remi is needed by php-mysqlnd-5.4.9-1.el6.remi.x86_64

so I tried installing that rpm file and got this error

rpm -ivh ftp://ftp.pbone.net/mirror/rrpms.famillecollet.com/enterprise/6/test/x86_64/php-pdo-5.4.6-1.el6.remi.x86_64.rpm
Retrieving ftp://ftp.pbone.net/mirror/rrpms.famillecollet.com/enterprise/6/test/x86_64/php-pdo-5.4.6-1.el6.remi.x86_64.rpm
curl: (9) Server denied you to change to the given directory
error: skipping ftp://ftp.pbone.net/mirror/rrpms.famillecollet.com/enterprise/6/test/x86_64/php-pdo-5.4.6-1.el6.remi.x86_64.rpm - transfer failed

I used the ftp links because I have no idea how else to get them to the server. I think I am getting overly frustrated with this, but I have to get this driver installed for any of my scripts to function correctly.

Any help would be greatly appreciated!

share|improve this question
1  
use a package manager -- yum on CentOS –  Hubert Kario Dec 16 '12 at 16:26
    
You made a typo, that's why the second command didn't work. –  Michael Hampton Dec 16 '12 at 20:29

1 Answer 1

up vote 2 down vote accepted

Try to add the Remi repository to yum and install it that way. Yum will automatically deal with all the dependencies for you, so you don't have to follow the breadcrumb path all the way to the final dependency. Saves you lot of time and frustration :)

As root user, run these commands:

wget http://rpms.famillecollet.com/enterprise/remi.repo -O /etc/yum.repos.d/remi.repo
yum --enablerepo=remi-test install php-mysqlnd

The first command will retrieve the repository configuration file for Remi's repo. The second command will install the php-mysqlnd package and will also use the Remi repo to install it.

share|improve this answer
    
As soon as my server decides to come back online I will see if this works, me messing around knowing nothing about this is probably is what caused it to go down. –  kira423 Dec 16 '12 at 16:45
    
Messing around is the best way of learning things :) Let me know how it works out for you once you have it back on track. –  Oldskool Dec 16 '12 at 16:46
    
unfortunately even a hard reboot isn't bringing it back online I fear I broke my server completely –  kira423 Dec 16 '12 at 16:54
    
Finally was able to try this out, but this is what it says remi | 2.9 kB 00:00 remi/primary_db | 451 kB 00:00 Setting up Install Process No package php-mysqlnd available. Error: Nothing to do which is the same thing I keep being told when I try to install anything... I am not sure what to do. –  kira423 Dec 17 '12 at 0:27
    
@kira423 I just looked at Remi's site and it appears the package your are looking for is actually in the remi-test repository. So try yum --enablerepo=remi-test install php-mysqlnd instead. –  Oldskool Dec 17 '12 at 0:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.