Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting the following error when i try to connect to a remote host.

Can't connect to X11 Windows server using "0:0" as the value of the display variable.

How do i get past it?

Other info:

  1. I am running a windows machine and the host is unix based.
  2. I have Xming installed.
  3. I have given the display command as export DISPLAY=0:0
  4. I have checked X11 option in SSH.
share|improve this question
1  
Try not to export the DISPLAY option. It should be set automatically by ssh when X11 forwarding is turned on. –  Dmitri Chubarov Dec 17 '12 at 10:37
1  
Did you verify x11 forwarding is enabled in your ssh server config? –  Zoredache Dec 17 '12 at 16:33
add comment

2 Answers

Don't attempt to set the DISPLAY environment variable on the remote host. This is set automatically by ssh and should not be changed.

share|improve this answer
add comment

X11 forwarding will work if the following conditions are met:

  • X server installed locally
  • X11 forwarding checked in Putty (or -X option of ssh at the command line)
  • X11 forwarding enabled in the server config (/etc/ssh/sshd_config)
  • package providing the xauth binary installed on the remote machine
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.