Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have recently setup a brand new install of SBS 2011 and it is working well. Exchange is running as advertised and all users are happy.

Now, there are 2 users who would like to work outside of the office and require email setting up in Outlook. No problem - Exchange over HTTP. However for some reason it's not working.

They can access Outlook Web Access okay, but for some reason Exchange over HTTP / HTTPS isn't working. The error message I receive in Outlook is:

"The name cannot be resolved. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action."

I've tried temporarily turning off the Firewall on both the server and the client but this doesn't help at all. Is there something I'm missing or is there a permission that needs enabling to allow Exchange over HTTP to work??

Many thanks

share|improve this question
    
Have you tried testexchangeconnectivity.com? If you're seeing DNS errors, that'll pinpoint them pretty precisely. –  Driftpeasant Dec 19 '12 at 18:54
    
What type of certificate is deployed in your organization (internal or third party)? Can you go to testexchangeconnectivity.com and perform a test for Outlook anywhere? Can you turn off iPV6 once and try checking the connections? Do you have a proxy firewall (ISA/TMG?) in between the internet and your internal network? –  user150519 Dec 21 '12 at 5:18
add comment

3 Answers

"The name cannot be resolved. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action." is not a firewall issue, but a DNS issue.

When the clients sit on the internal network, they are able to resolve and connect to the Exchange/SBS server using it's internal hostname or fqdn (ie. sbsserver.domain.local).

Since domain.local, let alone sbsserver.domain.local is unlikely to exist in the public DNS namespace, name resolution fails when clients try to connect

share|improve this answer
    
I have entered the full internal name where Outlook asks for the Exchange Server, then in 'More settings' and under the Exchange over HTTP settings I've put the publicly accessible name exchange.mydomainhere.com –  Rob Dec 17 '12 at 11:49
    
This is the same domain that is used for OWA which works fine. –  Rob Dec 17 '12 at 11:50
    
I have got exactly the same problem; network users can use Outlook fine, it even works remotely on iPhone, iPad and WinPhone7 devices ... the only thing that doesnt work remotely is Outlook on Windows Desktop (with or without a VPN to the office) ... OWA works fine, DNS exists (obviously or iOS wouldnt connect) so what on earth is Outlooks problem?? –  Dan Feb 21 '13 at 11:42
add comment

Your server is likely to have a static IP. If you own a business, you can simply ask your Internet Service Provider for a fixed IP and forward appropriate port in your router configuration. Modifying information for Exchange auto-configuration service should be updated with the new external Exchange URL.

That way, you would simply replace your client to configuration address with your fixed IP.

share|improve this answer
add comment

Outlook Anywhere (formerly known as RPC over HTTP) requires some configuration steps apart from Outlook Web Access/ActiveSync. Just because users can access OWA or ActiveSync does not mean Outlook Anywhere will work. Outlook Anywhere does use IIS but it's a little more complex than OWA/AS.

http://exchangeserverpro.com/how-to-configure-exchange-server-2010-outlook-anywhere/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.