Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Like I mentioned in title I have a problem with my mail, Google treated them as spam. On my VPS I have CentOS 5 Kloxo Host-InA-Box.

So I set all 5 mx records for GoogleApps:

conmendo.com    MX  10  ALT1.ASPMX.L.GOOGLE.COM
conmendo.com    MX  20  ALT2.ASPMX.L.GOOGLE.COM
conmendo.com    MX  30  ASPMX2.GOOGLEMAIL.COM
conmendo.com    MX  40  ASPMX3.GOOGLEMAIL.COM
conmendo.com    MX  5   ASPMX.L.GOOGLE.COM

DKIM:

google._domainkey   TXT     -   v=DKIM1; k=rsa; p=MIGfMA0GCSqG...
(key provided by GoogleApps)

SPF:

@   TXT     -   v=spf1 include:_spf.google.com ~all

(as it say here: http://support.google.com/a/bin/answer.py?hl=en&answer=178723)

On my VPS i have installed Wordpress and plugin "WP-Mail-SMTP" so i can send my mails using SMTP option. Now when i try to test my mails like new user registration or just by plugin option "test email" all my mails are going to spam folder. Tested with gmail and hotmail.

This is example of test mail that always fail and goes in spam folder:

Delivered-To: thebunnynation@gmail.com Received: by 10.229.117.223
with SMTP id s31csp46562qcq;
        Mon, 17 Dec 2012 05:20:09 -0800 (PST) Received: by 10.66.87.202 with SMTP id ba10mr42282031pab.72.1355750409361;
        Mon, 17 Dec 2012 05:20:09 -0800 (PST) Return-Path: <info@conmendo.com> Received: from mail-pb0-f41.google.com
(mail-pb0-f41.google.com [209.85.160.41])
        by mx.google.com with ESMTPS id d7si13303798paw.298.2012.12.17.05.20.08
        (version=TLSv1/SSLv3 cipher=OTHER);
        Mon, 17 Dec 2012 05:20:08 -0800 (PST) Received-SPF: neutral (google.com: 209.85.160.41 is neither permitted nor denied by best
guess record for domain of info@conmendo.com) client-ip=209.85.160.41;
Authentication-Results: mx.google.com; spf=neutral (google.com:
209.85.160.41 is neither permitted nor denied by best guess record for domain of info@conmendo.com) smtp.mail=info@conmendo.com; dkim=pass
header.i=@conmendo.com Received: by mail-pb0-f41.google.com with SMTP
id xa7so3611524pbc.0
        for <thebunnynation@gmail.com>; Mon, 17 Dec 2012 05:20:08 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=conmendo.com; s=google;
        h=date:to:from:subject:message-id:x-priority:x-mailer:mime-version
         :content-transfer-encoding:content-type;
        bh=st1/rxzSXOLicwNXDIcmmqBRpMu03FlOdst59TvXqHY=;
        b=GFYB/oOCbOteiiVZ9mHjkAeTAZgDfEQGtdv36eiaUvCr0w6Uqq/ShLZaMy5F3LA72Z
         vaQ4orZJXGQEu5eT8vHywDHuY1V4XlhNMUlCbQHha5JfgUvJFshoZDk6JxnpIHcbCNhV
         u5Lje0ViCDZDNBQKsVzbPp70Y7jGD2CRxUwAM= X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=google.com; s=20120113;
        h=date:to:from:subject:message-id:x-priority:x-mailer:mime-version
         :content-transfer-encoding:content-type:x-gm-message-state;
        bh=st1/rxzSXOLicwNXDIcmmqBRpMu03FlOdst59TvXqHY=;
        b=FzVUI/bS2MP4kKiEYJbNxKtOQjg2hBKt6f8tp0rasKaWVEz/lxdLhk5tdM93ZIC0LR
         7pBvL+u9NDd/EYQvEu9tUKgAju7dimYCwwXEorR40+gL4AIv2jJTczCFLz+pDXqp3odd
         EhT6lZMPEuctzUL1YrCwqpXOR9gsfS+NitQnXUJzAhLg93xYlCMj7k7F5IYWqhCOP25c
         Cy+JNextm7DFJa/ElN5JONWpi3JAWbVibMIS+pRwvFodzTbOUdM0eSZr8+6dstRvxNaX
         PrkAs5xDlUKi9TQPoKC7Qub8z9vAn0f28iu7e1/JTg/HY6Zlw0d5AoWXKr36dKWmgp7E
         S0dw== Received: by 10.66.82.162 with SMTP id j2mr42540741pay.13.1355750408078;
        Mon, 17 Dec 2012 05:20:08 -0800 (PST) Return-Path: <info@conmendo.com> Received: from www.conmendo.com ([184.164.141.58])
        by mx.google.com with ESMTPS id ol4sm8188620pbb.58.2012.12.17.05.20.05
        (version=SSLv3 cipher=OTHER);
        Mon, 17 Dec 2012 05:20:06 -0800 (PST) Date: Mon, 17 Dec 2012 13:20:04 +0000 Return-Path: info@conmendo.com To:
thebunnynation@gmail.com From: Conmendo - Balkanska Zelena Milja
<info@conmendo.com> Subject: WP Mail SMTP: Test mail to
thebunnynation@gmail.com Message-ID:
<80ef1194fb2beb1f8991755cfd575ee0@www.conmendo.com> X-Priority: 3
X-Mailer: PHPMailer 5.2.1
(http://code.google.com/a/apache-extras.org/p/phpmailer/)
MIME-Version: 1.0 Content-Transfer-Encoding: 8bit Content-Type:
text/plain; charset="UTF-8" X-Gm-Message-State:
ALoCoQn2NFANF3mJYeOLr5S2TkXhQDeqrdUdl5OII/S3QdokwQ0BvO+oeo/6M7R9LDC5JfNs1Bq2

This is a test email generated by the WP Mail SMTP WordPress plugin.

Right now is more then 5-6 days i try to solve this problem but nothing. I check huge amount of tips how to sort this problem but all they point to same thing, create TXT record for SPF with next value "v=spf1 include:_spf.google.com ~all". Do i miss something because at this point i dont know what else i can do. If anyone can help me i would be really grateful.

share|improve this question
add comment

1 Answer 1

I'd fix this, for starters:

Authentication-Results: mx.google.com; spf=neutral (google.com: 209.85.160.41 is neither permitted nor denied by best guess record for domain of info@conmendo.com)

According to dig, you don't have an SPF record for conmendo.com.

share|improve this answer
    
Ok here is 2 pictures, one from Kloxo DNS settings and second from www.mail-tester.com where it say i dont have SPF record even i put that in my DNS. img825.imageshack.us/img825/1265/dns01.jpg img407.imageshack.us/img407/1271/mailcheck01.jpg –  Dario Dec 17 '12 at 18:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.