Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Ok, so I have a small php script that sends an confirmation email after signup.. but it isn't working.. I know it isn't the code as the script works any where else, but I have made sure sendmail is installed, as well as checked my php.ini file.. The thing is, if an email is sent from 1 local email to another it will work, but it wont work sending to outside website providers.. here is an image of what I mean.

http://imgur.com/IjYnd

Hopefully that can help.. I was using dovecot but just switched it over to Courier i didn't know if it would solve the problem, but I can see now it didn't :/

Here is a link to a paste of my maillog. http://pastebin.com/QsZq9RbR

Also I did find a log named maillog-20121216 so i opened it up and it has this, which isn't in the pastebin post

Dec 17 00:00:40 cserver exim[12268]: 2012-12-17 00:00:40 cwd=/ 2 args: /usr/sbin/exim -bV
Dec 17 00:00:40 cserver exim[12268]: 2012-12-17 00:00:40 Cannot open main log file "/var/log/exim_mainlog": No such file or directory: euid=0 egid=0
Dec 17 00:00:40 cserver exim[12268]: exim: could not open panic log - aborting: see message(s) above
Dec 17 00:00:41 cserver exim[12273]: 2012-12-17 00:00:41 cwd=/ 4 args: /usr/sbin/exim -bV -C /etc/exim.conf.buildtest.work.utMeQPXmJY3yr_Rm
Dec 17 00:00:41 cserver exim[12273]: 2012-12-17 00:00:41 Cannot open main log file "/var/log/exim_mainlog": No such file or directory: euid=0 egid=0
Dec 17 00:00:41 cserver exim[12273]: exim: could not open panic log - aborting: see message(s) above

This the output of exim_paniclog

2012-12-17 09:46:32 socket bind() to port 25 for address (any IPv6) failed: Address already in use: daemon abandoned
2012-12-18 05:33:01 1TkuTt-00038k-O2 User 0 set for local_delivery transport is on the never_users list
2012-12-18 06:36:10 1TkvT0-0003JX-NS User 0 set for local_delivery transport is on the never_users list
2012-12-18 07:29:52 1TkvT0-0003JX-NS User 0 set for local_delivery transport is on the never_users list
2012-12-18 08:29:52 1TkuTt-00038k-O2 User 0 set for local_delivery transport is on the never_users list
2012-12-18 08:39:20 1TkxOC-0003eU-C6 User 0 set for local_delivery transport is on the never_users list
2012-12-18 09:36:11 1TkyHC-0003nd-T1 User 0 set for local_delivery transport is on the never_users list
2012-12-18 10:41:26 1TkvT0-0003JX-NS User 0 set for local_delivery transport is on the never_users list
2012-12-18 12:29:52 1TkuTt-00038k-O2 User 0 set for local_delivery transport is on the never_users list
2012-12-18 15:29:52 1TkuTt-00038k-O2 User 0 set for local_delivery transport is on the never_users list
2012-12-18 19:33:02 1TkyHC-0003nd-T1 User 0 set for local_delivery transport is on the never_users list
2012-12-18 20:00:14 1Tl817-0005tq-WA User 0 set for local_delivery transport is on the never_users list
2012-12-18 20:16:54 socket bind() to port 25 for address (any IPv6) failed: Address already in use: daemon abandoned
share|improve this question
2  
Have you checked /var/log/maillog for any errors? –  Safado Dec 17 '12 at 15:13
    
You may want to disable your firewall and try again. –  Zim3r Dec 17 '12 at 15:22
    
You should have obscured the user name and left the domain name visible. –  Michael Hampton Dec 17 '12 at 19:02
    
@MichaelHampton was gmail and yahoo –  kira423 Dec 17 '12 at 20:56
    
@Safado ahh yeah I have checked it but have no idea what any of it means. pastebin.com/QsZq9RbR –  kira423 Dec 17 '12 at 21:06

1 Answer 1

up vote 0 down vote accepted

It seems that local delivery is happening and remote email account mails are not getting delivered. Can you stop firewall and try to send the mail?

Also check your /etc/resolv.conf file and use 8.8.8.8 and try again. It is possibly due to firewall.

Try sending mail to your gmail or yahoo account from the Shell (command line) of the server. Post the out put and logs (/var/log/mail.log) too.

share|improve this answer
    
I did stop the firewall and tried, it still did not work, so I am not sure what could be going on. Nothing was added to the maillog after running the mail command, nor did it send the email upon sending it just said EOT which I assume is a confirmation but I do not know for sure. I am new to all this owning a server stuff :/ –  kira423 Dec 19 '12 at 1:06
    
as I can see you are using cpanel for managing you server. also did you check your resolv.conf file. use public resolver as I mentioned above and try again. –  PratapSingh Dec 19 '12 at 9:54
    
I was told that if I changed that file I would be in breech of contract with my VPS provider, so there isn't much i can do about that. –  kira423 Dec 19 '12 at 17:14
    
I am not sure what kind of VPS provider is this and I would also like to know if you are running csf then disable it using csf -x ... also add another nameserver entry to the resolve.conf file as "nameserver 8.8.8.8" do not remove existing one so this way you are not violating anything.. I hope this is convenient .. –  PratapSingh Dec 19 '12 at 17:32
    
how do I check if I am running csf? when i try that command it says command not found. –  kira423 Dec 19 '12 at 21:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.