Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm replacing a faulty D-Link unmanaged switch with a ZyXel ES-2024A managed switch.

Right now I don't want to do anything fancy, no VLANs or stuff right now, I just want to connect the 2024A to the Router (Link Net LW-N615R) to provide Wan access and below that to another unmanaged switch to provide access to additional computers and devices. Network diagram

Until now I have changed the Default Management IP Address to 192.168.1.2 as the Router is 192.168.1.1.

Changed the Default gateway from 0.0.0.0 to 192.168.1.1.

Pinging to the ISP DNS with the Switch´s Diagnostic utility was then successful, but when I tried through the OS Command Line it showed all packets lost, plus I can't browse the Web and Windows 7 shows no Internet access.

Additionaly the devices on the second unmanaged Switch don´t apear to be accessible.

I'd really appreciate any help.

share|improve this question
    
Did you make sure that DHCP is disabled on the switch, those ZyXel managed switches have DHCP servers built-in. –  user72593 Dec 17 '12 at 20:58
    
EUGH. DHCP on a switch? spits .. Well that's ZyXel on my shitlist. –  Tom O'Connor Dec 17 '12 at 21:11
    
They're not bad devices, i've used a few in PoE and non PoE settings, cheap gigabit and alot of features, but sometimes too many features just gets in the way of a simple task ;) –  user72593 Dec 17 '12 at 21:13

1 Answer 1

Step 1: If you connect directly to the managed switch, do you get a valid IP address from the DHCP server on the LinkNet router?

Can you ping 192.168.1.1, 192.168.1.2 and 8.8.8.8 and the gateway of your ISP?

Yes, then:

Step 2: Try this again from the Unmanaged switch, and release/renew the DHCP lease from your test device.

Do you still have a valid IP address? Can you still ping 192.168.1.1, 192.168.1.2 and 8.8.8.8 and the gateway of your ISP?

No?

Try connecting the switches with a Crossover cable instead of a straight-through one. Cross-connecting older (or less clever) switches often needs a Crossover cable. Newer/intelligent switches support Auto-MDI/X and will automatically negotiate a crossover link.

Yes? Check the default route, and also that any VLAN configuration on the managed switch is set to "Untagged VLAN 1" on all ports (effectively making it a flat switch).

Step 3: Are you using the DNS servers from your ISP? Can you ping those from anywhere on the network? If not, try pinging Google's public DNS (8.8.8.8, 8.8.4.4). If that works, your ISP is being dumb. -- Use Google's public DNS, and be happy.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.