Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My server emails me when any messages goes to root. cron sends me messages. Today I got over 300 emails from my server all of which are

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/suhosin.so' - /usr/lib/php5/20090626+lfs/suhosin.so: cannot open shared object file: No such file or directory in Unknown on line 0

I have no idea why. I went to debug it however 5hours ago it stopped so theres nothing i could look at except maybe logs. Why did this maybe happen? Disk isn't full and I have enough ram available.

share|improve this question
3  
The first obvious question is "does /usr/lib/php5/20090626+lfs/suhosin.so exist?" The second is "do you have any automatic update setup that could have upgraded the php5 package while the server was being used?" Other than that, it's hard to say why this happened. What is the time frame of these 300 messages? Over a few minutes? Over a few hours or days? –  DerfK Dec 18 '12 at 0:46
    
Probably should also consider some kind of email limiter. Having your logging software lob 300 emails at you isn't exactly useful or productive –  TheLQ Dec 18 '12 at 0:58
    
@DerfK: No it doesnt exist (wtf). But... I had this cron job for a year and it only acted up yesterday. Its acting up now and I dont see any problems. I dont need the job so i'll disable it for now but i wonder what caused it. Also I see my job is * * * * * flock -xn /root/lock/wpcron.lock -c /root/apps/wp-cron.sh. AFAIK i have no automatic upgrade tool or anything disabling it in the background. All I touched in the last two days was adding a aspx site and enabling a new build to one of my .NET service apps. Both have nothing to do with php nor wordpress –  acidzombie24 Dec 18 '12 at 2:27
    
FYI The subject is flock -xn /root/lock/wpcron.lock -c /root/apps/wp-cron.sh the sh is cd /var/www/mysite/wordpress/ php5 wp-cron.php but that space is a newline. –  acidzombie24 Dec 18 '12 at 2:30

1 Answer 1

Did you or someone did a system / software update?

It is possible the suhosin package got updated but apache still trying to use the old path when spawning child process. The problem went away when the system update is done or someone restarted apache.

There is a debian bug report matching your situation. The cause is suhosin being removed, but not purged.

On debian/ubuntu base system

  • Apache2 restart history - /var/log/apache2/error.log
  • Package install/update history - /var/log/apt/history.log
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.