Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have tried just about everything I can think of on this one. I am currently trying to increase the max file upload size on our apache owncloud server.

I have changed the /etc/php.ini values for: upload_max_filesize and post_max_size

After restarting the httpd service, the file size has not yet changed. I tried several different values without success. I then edited the .htaccess in the root of the owncloud directory for upload_max_filesize and post_max_size, restarted, and still am not able to surpass the 2m limit.

I created a phpinfo file, and it does in fact say that it is pulling from the /etc/php.ini file.

Any help would be greatly appreciated.

share|improve this question
    
What size limit you are looking for ? Also, which php.ini file you are changing .. means location ? –  GeekRide Dec 18 '12 at 14:19
    
I'm trying for 200mb. I tried that as 200m 200MB 200 MB and 200 m. None of those seem to work. I've been editing the /etc/php.ini –  Mike Dec 18 '12 at 14:24

2 Answers 2

OP back. I figured out the issue. I ran php -c /etc/php/php.ini -i | grep upload_max_filesize and discovered a small typo elsewhere in the php.ini file. (I attempted to edit the timeout value, and had left in a parenthesis). After taking out the parenthesis, and restarting the service, the upload value was correctly adjusted.

share|improve this answer
    
Congrats! Please mark your solution as the accepted answer so others may benefit. (-: –  KM. Apr 9 at 17:53

Create a sample.php file with phpinfo() function in your owncloud document root to check which php.ini is being used, its location and parameters values.

<?php
phpinfo();
>

Then change the following parameters in php.ini and restart the web server and relogin to owncloud before try uploading again.

post_max_size = 200M
upload_max_filesize = 200M

Make sure you are using latest version of owncloud.

share|improve this answer
    
Somesh, Here's what I get for loaded configuration file: Loaded Configuration File /etc/php.ini Running PHP version 5.3.3 It does not seem that editing post_max_size, and upload_max_filesize to those values and restarting the service worked. I am currently running owncloud version 4.5.4 which it says is up to date –  Mike Dec 18 '12 at 15:04
    
run the following cmd to check all php.ini file and their upload values: updatedb && grep upload_max_filesize locate php.ini "locate php.ini" value is in backtick .. I don't know how to place that in comment. ` –  Somesh Dec 18 '12 at 15:11
    
So I did do that, and it found 2 files (in usr/share/doc) set as 2M. I set them both as 200M, and restarted the service. After refreshing the phpinfo page it still seems like for some reason it is stuck on 2M. –  Mike Dec 18 '12 at 15:23
    
Can you share value of "Loaded Configuration File" from your phpinfo output? If you change value in php.ini, restart web service, refresh phpinfo page then it should reflect in phpinfo unless you are making changes in diff php.ini. –  Somesh Dec 18 '12 at 15:27
    
Loaded Configuration File /etc/php.ini Then for the output of your command I get: /etc/php.ini:upload_max_filesize = 200 and /usr/share/doc/php-common-5.3.3/php.ini-development:upload_maxfilesize = 200 and /usr/share/doc/php-common-5.3.3/php.ini-production:upload_maxfilesize = 200 –  Mike Dec 18 '12 at 15:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.