Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having trouble with a CentOS server running on AWS. This is CentOS 5.6 i386 from RightImage, but the problem was the same on all RightScale AMIs.

When issuing the following command:

yum install mysql mysql-server mysql-devel

the only packages proposed by yum are MySQL-devel-community and MySQL-server-community. Which would't be a problem, except this package is old/incomplete, because it does not create a "mysqld" service, only a /etc/init.d/mysql (notice the missing d). That would't be a problem, I can start the service by doing ./etc/init.d/mysql start, and it starts OK, but there is no "mysql" (or other mysql*) command available.

If I try to force a different version (yum install mysql50-server...) I get this yum error:

mysql-5.0.77-4.el5_6.6.i386 from updates has depsolving problems
--> mysql conflicts with MySQL-server-community

(even when I don't have MySQL-server-community installed).

I have tried this before and after yum update, in a fresh image.

How can I install a working version of MySQL? I'm stuck on CentOS 5 because I want to install Kloxo (which does not yet support CentOS 6). I'm not interested in Webmin, and I can't afford cPanel.


share|improve this question

1 Answer 1

Perhaps try adding the REMI repo and install (or upgrade, if it complains about it already existing) to MySQL 5.5.28. This will give you EPEL and REMI:

## This was taken from the official REMI page
wget http://dl.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-5.rpm
rpm -Uvh remi-release-5*.rpm epel-release-5*.rpm
share|improve this answer
REMI is not quite stable in certain parts.Anyway, I solved it by disabling the rightscale-epel repository. Thanks anyway. –  Marius Stuparu Dec 18 '12 at 16:12
@MariusStuparu Remi MySQL and PHP packages have been rock solid for me for years. –  Michael Hampton Dec 18 '12 at 18:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.