Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a HP ProLiant MicroServer running Windows Server 2012. It has the Hyper-V role installed, and I have tried guest VMs running both Windows Server 2012 and 2008 R2.

The issue I have is that on shutdown (whether in the guest OS or via Hyper-V Manager), reboot, or just attempting to "Turn Off" a guest machine, Hyper-V Manager reports the status as "Stopping" and takes anything between 5 minutes and several hours to get any further:

enter image description here

Any open connection to a guest machine during this progress seems to just freeze at the point it should actually switch off or restart.

With a bit of investigating, it seems that it is somehow related to networking. Ideally I want to keep the virtual switch set up as it is. It is using the on-board Broadcom NetXtreme I Server adapter configured as an External network with the host having access too. However switching this to an Internal network (thereby disassociating it from the adapter) causes the issue to go away.

Integration Services are installed on the guest OS and I've updated the drivers for the adapter on the host OS to the latest version direct from the Broadcom website. I also found a thread on the TechNet forums and tried what was listed there, including disabling power management on the adapter, and I disabled every single offloading option I could find both in Hyper-V options and the device properties. None of this has helped.

How can I try to resolve this "Stopping" issue?

share|improve this question
    
Do you have another NIC that you can dedicate to creating a virtual network for your VM's and leave the Broadcom NIC for management traffic? Also, for what it's worth, I don't find Hyper-V networking to be as intuitive as vSphere networking. –  joeqwerty Dec 20 '12 at 2:26
    
@joeqwerty Thanks for your suggestion, I've just tried with another PCI-E adapter (HP branded, Intel based) and the same problem occurred. Not sure where to go from here! –  Graham Wager Dec 20 '12 at 11:57

3 Answers 3

We had the same problem and it turned out to be setting that allows sharing the physical network card for management purposes in Hyper-V Virtual Switch settings. When I disabled the shared MGM support the system hung on shutdown/restart. When I turned it on, it started to work.

share|improve this answer
    
"When I disabled the shared MGM support the system hung on shutdown/restart. When I turned it on, it started to work" -Slavius Happened to me as well and that fixed it. Thank you very, very much. Only one vm was affected, the other two on the same host worked fine. The only difference was the problem vm was running Exchange 2013. The host and all three vms are running Windows 2012. There is now a hotfix out: support.microsoft.com/kb/2823643/en-us Haven't tried it. –  user186925 Aug 24 '13 at 2:25
up vote 1 down vote accepted

I managed to resolve this issue by removing ADDS from the host machine and moving it onto a VM.

I'm not sure why this worked as having my previous Server 2008R2 machine configured this way was fine, but I'm no longer seeing the problem.

share|improve this answer

Start by confirming your suspicion that it is networking. Disable your network card and shut it down. Does the problem go away? If not, try removing the network card. If it does shutdown properly, try just disconnecting the network (from the guest settings). If it still shuts down properly after that, I would try deleting all the virtual network cards and recreating them.

CAUTION: When you do this, it will break your snapshots because when you restore from a snapshot it will try to put the network back the way it was saved in the snapshot but the network card will not exist. Even if you recreate the network you will have this problem. It looks like you may not be in a production environment so I am guessing you can just rebuild the virtual network stack.

Another thing you can try is set the NIC to use an internal nic instead of external.

reply back with what you found, and I will help you continue to troubleshoot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.