Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed application called REDMINE on my localhost, using ruby on rails. It is accessible webrick script through localhost:3000, on my PC. Now I want to shift to apache2 passenger, I tried everything. Every possible link of redmine, but couldnt get it running through passenger. I installed passenger and all dependences, but still when I set virtualhost and in that put RailsBaseURI or RailsEnv etc the apache rejects it. And apache doesn't say there is some misspelling.....

What do i have to do? How to configure it so that this ruby rail app can be accessed?

Sorry but I tried setting this up for 3 days and was not able to succeed so I am becoming little bit lunatic and crazy :)


my system : Ubuntu 12.10, apache2.2.22, Ruby-1.9.1 passenger-3.0.18

edit2: I followed method described in this how to install redmine

got it working on localhost:3000 using WEBrick but i got stuck up in switching over to Apache2-passenger, i have installed all the modules of apache, gems and have enabled Vhost also but when i create a file in for redmine in sites-available folder apache fails to restart and show error of misspell....

share|improve this question

closed as not a real question by Michael Hampton, mdpc, TheCleaner, faker, mfinni Dec 20 '12 at 20:54

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Port 3000 is the webserver that comes with redmine and is an out of the box webserver running WEBrick. For production, you will want to use passenger. You do this by configuring a virtual host file for apache. This should help redmine-passenger for centos or redmine-passenger for ubuntu. If you are still stuck, try to create a virtual host file and paste it back in your question so we can see where it might be going wrong. Make sure iptables allows port 80 and the redmine service isn't running as that is what is making port 3000 listen on your server.

share|improve this answer
i tried following one also!!……… nothing works!! i am on this since last 3 days!! :) that might be because lack of skills(i honestly accept!!) – rathin2j Dec 21 '12 at 4:34
hi i m using ubuntu 12.10, and i had followed the same link that u gave and many others there ones but it is showing error that it is not able to know which RailsBase URI i am defining my virtualhost file is as follows <code> <VirtualHost *:80> ServerName redmine Redirect permanent / localhost:3000 <Directory /var/www/redmine> Options Indexes FollowSymLinks -MultiViews +ExecCGI AllowOverride All Order allow,deny allow from all </Directory> </VirtualHost> </code></pre> – rathin2j Dec 21 '12 at 5:09
stab in the dark, but if you have followed the instructions to a tee, can you ensure SELINUX is set to permissive or disabled? It is hard setting this up for the first time, so keep trying as you will get a better understanding over time – Oli Dec 21 '12 at 10:01
@Oli-ok sir, i'll keep on trying, but mean while i need to get this worke DONE(others are waiting) so will make this "redmine" available through webrick, then later on will switch over.. ;) will post update if successful!! – rathin2j Dec 25 '12 at 11:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.