Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

While trying to install kernel-uek-2.6.32-300.7.1.el5uek.x86_64.rpm I got following error :( Pls help, really in trouble

 [root@nonprodsrv02 kdumprpm]# rpm -ivh kernel-uek-2.6.32-300.7.1.el5uek.x86_64.rpm

 warning: kernel-uek-2.6.32-300.7.1.el5uek.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 1e5e0159
 error: Failed dependencies:
    mkinitrd >= 5.1.19.6-71.0.10 is needed by kernel-uek-2.6.32-300.7.1.el5uek.x86_64
    oraclelinux-release is needed by kernel-uek-2.6.32-300.7.1.el5uek.x86_64
    udev < 095-14.27.0.1.el5_7.1 conflicts with kernel-uek-2.6.32-300.7.1.el5uek.x86_64
 [root@nonprodsrv02 kdumprpm]#
share|improve this question
    
tried mkintrd instlallation(oss.oracle.com/ol5/SRPMS-updates/…), it succeed but still unable to run rpm. –  previen Dec 20 '12 at 21:43
    
Have you contacted Oracle support? –  mdpc Dec 20 '12 at 21:45
    
Thank you, any idea abt last line udev < 095-14.27.0.1.el5_7.1 conflicts with kernel-uek-2.6.32-300.7.1.el5uek.x86_64 –  previen Dec 20 '12 at 21:53
    
@mdpc - not really. Home users don't tend to install Oracle. –  ChrisF Dec 20 '12 at 22:10
    
I solved the issue by applying an older version "rpm -iv --nodeps kernel-uek-2.6.32-200.13.1.el5uek.x86_64.rpm" Beware to use rpm -iv --nodeps (since no dependency required for kdump installation) –  previen Dec 21 '12 at 0:35

1 Answer 1

It looks to me like:

  1. the udev package should be upgraded.
  2. The oraclelinux-release package needs to be installed
  3. the mkinitrd package should be upgraded.

This is the problem using rpm straight on a single package and not using some type of packaging support system like yum which catches these issues and tries to address them. I don't know what Oracle Linux supports in this area.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.