Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This comes from here

Now it runs, but when i run it using the root crontab, it told me:

*tail: /var/log/backupeitor.log: file truncated
/bin/sh: /home/backup/scripts/ Permission denied*

Permissions for the file:

*srv156:/home/backup/scripts$ ls -alrt
insgesamt 28
drwxrwxrwx 2 root root 4096 19. Sep 13:23 off
-rwxrwxrwx 1 root root 1274 24. Okt 15:16
-rwxrwxrwx 1 root root  302 24. Okt 15:16
drwxrwxrwx 5 root root 4096 18. Dez 14:55 ..
drwxrwxrwx 3 root root 4096 20. Dez 09:48 .
-rwxrwxrwx 1 root root 3393 20. Dez 22:49

Any idea?

share|improve this question
having permissions of 777 (rwxrwxrwx) is a bad idea. It isn't related to your error, but any other user or service on that system could arbitrarily modify those scripts to do anything they want, which would then be executed by root. – Zoredache Dec 20 '12 at 22:21

Please check my answer in your other post, properly will fix both problems.

share|improve this answer


Shebang Changed, path to /usr/bin/perl changed as @John-Siu says it worked!


share|improve this answer
Please consider accepting(put a check mark) my answer on both questions. Thank you :) – John Siu Dec 21 '12 at 1:08
This could be a comment, not an answer – F. Hauri Dec 30 '12 at 20:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.