Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I just lost about all my hair on this one:

I got

  • an ubuntu 12.04 machine on ip address, gateway
  • A router on, running a forwarding dns
  • ping - or any ip address on the net works

but resolving doesn't work.

  • ping

    unknown host
  • route -n

    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         UG    100    0        0 eth0     U     1000   0        0 eth0   U     0      0        0 eth0
  • ifconfig

    eth0      Link encap:Ethernet  HWaddr 22:ab:01:01:77:86
              inet addr:  Bcast:  Mask:
              inet6 addr: fe80::20ab:1ff:fe01:7786/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:443 errors:0 dropped:0 overruns:0 frame:0
              TX packets:426 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:34620 (34.6 KB)  TX bytes:64400 (64.4 KB)
  • telnet 53

    telnet: Unable to connect to remote host: No route to host

What the heck is going on ?

share|improve this question
Can you please copy-past the value of /etc/network/interfaces ? – DJYod Dec 21 '12 at 9:12
Can you ping ? If that is the case your DNS isn't working but lowlevel TCP/IP is OK. (The telnet error may be confusing the matter here. Could be NOT indicative of the real problem.) If the ping (Google DNS server) also gives a no route the router also most likely the culprit, but I would suspect the NAT/routing part in stead of the DNS service. – Tonny Dec 21 '12 at 9:19
check your /etc/resolv.conf file weather it contains nameserver's detatil or not. – user128296 Dec 21 '12 at 9:36

2 Answers 2

Firewall on the router was blocking access to port :53 Added

-A RH-Firewall-1-INPUT -p udp -m state --state NEW -m udp --dport 53 -j ACCEPT
-A RH-Firewall-1-INPUT -p tcp -m state --state NEW -m tcp --dport 53 -j ACCEPT

Sorry for the hassle (and thanks sejo for helping out !)

share|improve this answer
So I was right all along in my comment above :-) – Tonny Dec 21 '12 at 9:56
Yup - it is. Thanks – Francis Martens Dec 21 '12 at 16:13

edit you interfaces to make it look something like this

sudo vi /etc/network/interfaces

auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
    # dns-* options are implemented by the resolvconf package, if installed

You'll most probably want to change your dns-nameserver - if you don't know what that is, just use I would assume your IP settings are ok so no need to change them. Also update the dns-search and dns-domain and append your internal domain name. If you update your resolv.conf file, it may get over ridden when your network services restart as the resolvconf package will take what is placed in your interfaces file and put them in to your resolv.conf file. Thus the problem may reappear. Also the routers firewall may be blocking ports or not serving DNS. Which is why you could try This will give you external DNS resolution. If internal DNS isn't working, then you need to ensure a DNS server is contactable and running. Otherwise use the /etc/hosts file.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.