Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a PHP-FPM and nginx setup that has been working perfectly on Ubuntu Desktop 12.04. The webserver's files are served from a directory called /www, which is set as the root of the server.

Initially, /www was mounted as a VMware shared folder (because the Ubuntu Desktop is running as a guest os). However, due to performance issues with shared folders (seeing a 2 second delay!), I am testing out samba shares.

I have a folder called webfiles shared as a network share on my Windows 7 host. I am able to automount it to /www by mounting it as cifs in my fstab:

//192.168.1.7/webfiles /www cifs credentials=/home/user/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0 

The /www mounts fine on start up and I can create and delete files on it in Ubuntu. Nginx is also able to serve static files from it with no problem.

The problem is that once I want it to server PHP files through PHP-FPM, I start getting File not found. errors. This is despite the fact the setup worked perfectly, and the only thing that changed is, instead of a shared folder being mounted at /www, I now have a samba share.

I am not very familiar with samba, but what could be causing this?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Looks like there was a problem with the mounting. Instead of having windows pass the inode numbers, setting it so that Ubuntu generate the inode numbers fixes the problem:

//192.168.1.7/webfiles /www cifs credentials=/home/user/.smbcredentials,noserverino 0 0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.