Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a VPN working for the wired connection but it doesn't seem to work for the wireless connection.

I'm trying to get a VPN set up with both a wired and wireless connection. So to do so, after the connection is brought up, img calling pon settings. However, for a reason that I can't figure out, it works for the wired connection (eth0) but not for the wireless connection (wlan0). Here is /etc/network/interfaces/

 auto lo
 iface lo inet loopback

 iface eth0 inet dhcp
      post-up pon settings
      pre-down poff

 allow-hotplug wlan0
 iface wlan0 inet manual
      wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
      pre-down poff
      post-up pon settings

 iface default inet dhcp

 iface ppp0 inet ppp
      provider settings

I'm guessing there is something wrong with iface wlan0 inet manual. I tried replacing it with auto iface wlan0 inet and iface wlan0 inet dhcp (like for the wired one) but they did't work.

share|improve this question
    
How does your wlan0 interface get an IP address if you're not using DHCP? –  mgorven Dec 26 '12 at 0:17
    
good question. I'm not quite sure. It does get one though. Perhaps another line in the interfaces file is doing it or could there be another thing doing it? Wicd nor NM is installed. –  Scoop Dec 26 '12 at 1:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.