Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Dell PowerEdge R710 running Windows Server 2008 R2 Datacenter and which was part of a Hyper-V Failover Cluster. It has 8x Broadcom BCM5709C NICs and three are teamed together to be my "Virtual Machines Team". The team works fine, but I'm having an issue with Hyper-V. It refuses to create a virtual network out of the teamed adapter and errors out with a message that I don't have permissions to do so. When I check the teamed adapter's properties it is bound to the Microsoft Virtual Network Switch Protocol, Hyper-V just never went the extra step of making it into a virtual network.

As I said above, this server was part of a Hyper-V Failover Cluster with another identical machine. The other machine has the exact same settings and it's teamed adapter is working fine as a virtual network in Hyper-V.

Does anyone have any suggestions on how I can try to get this working? My other option is to reload the OS again and see if that helps. Suggestions will be highly appreciated.

share|improve this question
    
Short of doing the OS reload (again) how about renaming the server. Since you are receving permission errors this <b><u>might</u></b> resolve your error (?)... if it does and you get everything connected the way you want then try renaming your server back. –  AZee Dec 26 '12 at 18:44
    
Well, a little late for that, I already started the OS reloading. Actually it's already done, I'm now re-configuring it. –  Alex Dec 26 '12 at 18:49
    
Are you running the latest Firmware, Drivers, and Management Software? If not, go update and see if that resolves the issue. –  Chris S Dec 26 '12 at 20:22
    
@ChrisS, yes, I have the latest firmware and drivers from Dell installed on the machine for everything, not just the NICs. –  Alex Dec 26 '12 at 20:49

1 Answer 1

up vote 1 down vote accepted

After a couple of days of researching I think I've found the answer, and it was actually an issue with Hyper-V. Just to preset what was happening before I answer, I was attempting to optimize the host's network for Hyper-V. More on that can be found here.

Well, as part of the optimizations one of them was to add two registry entries. They are BelowTenGigVmqEnabled (also TenGigVmqEnabled) and BelowTenGigVmChimneyEnabled (also TenGigVmChimneyEnabled) to HKLM\SYSTEM\CurrentControlSet\services\VMSMP\Parameters. If those settings exist before you try to create a Hyper-V virtual network with a teamed adapter, you will get the permissions error. From what I saw, physical adapters don't have an issue if the settings exist or not when you create a virtual network out of them.

The proper way of using these settings is to configure the virtual network with Hyper-V then add the settings in and it all works fine. Also, I'm not sure if it was one or the other, but to be on the safe side I removed both, configured the virtual network, then added them back. I hope this helps someone.

share|improve this answer
    
I don't mean to slam someone before I've read their whole post, but that Accepted Answer starts with incorrect information right off the bat (TOE = TCP Offload Engine; iSOE is the iSCSI Offload Engine; VERY different things). We run BCM5709 chips in our Hyper-V R2 cluster and mucking around with registry settings has never come up (seems like an awful idea). –  Chris S Dec 28 '12 at 23:13
    
Looks like I linked to the answer on the other post. Are you referring to my question or to the answer on it? –  Alex Dec 28 '12 at 23:15
    
The answer, you're question seems reasonable. –  Chris S Dec 29 '12 at 0:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.