Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I perfectly configured my server and now I made 2 stupid mistakes, I updated perl along with it's dependencies and I made a dedicated TMP dir and included it in fstab to prevent code execution with a permission of 1777, now amavis shut down and it's not allowing any mail to be sent or received, I activated the webshell for perl as I thought that I broke some perl module and updated 2 modules, which wasn't the fix for my problem and now I need the perl webshell to get back to it's previous state before configuration, I deleted all it's directories but it still prompts the > which means it's configured and I also need to make sure that perl can write to TMP folder so could amavis start creating it's TMPs and get things working again, any ideas ?

share|improve this question
    
Can you provide relevant parts of /etc/fstab, output of mount, and amavis logs? –  coincoin Dec 26 '12 at 14:52
    
Error in processing, id=25467-01, mime_decode-1 FAILED: MIME::Parser: can't open tmpfile: Invalid argument (in reply to end of DATA command)) (!!)TROUBLE in check_mail: mime_decode-1 FAILED: MIME::Parser: can't open tmpfile: Invalid argument (!)PRESERVING EVIDENCE in /var/amavis/tmp/amavis-20121226T170616-25469 /var/temp /tmp ext3 loop,rw,noexec,nosuid,nodev 0 0 –  Danzka Dec 26 '12 at 15:13
    
Can you use pastebin.com to paste that? Otherwise the formatting is all wonky. –  mricon Dec 26 '12 at 15:30
    
sorry :) pastebin.com/10rVmsb9 and thanks a lot for your time –  Danzka Dec 26 '12 at 15:41
    
problem solved, thanks a lot :) –  Danzka Dec 26 '12 at 18:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.