Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Request Entity Too Large error while uploading files of more than 128KB over SSL

We have Apache 2.16 web servers where authentication is made via X509 client certificates (they come from chips cards). Here is the Directory configuration :

<Directory /directory>
        SSLVerifyClient optional
        SSLVerifyDepth 5
        SSLOptions +StdEnvVars +ExportCertData +OptRenegotiate

The authentication run fine, but from times to times, when the user try to upload a file the upload fail, and we find this in the apache error log :

[Thu Dec 06 09:14:25 2012] [error] [client] Re-negotiation request failed
[Thu Dec 06 09:14:25 2012] [error] SSL Library Error: 336068931 error:14080143:SSL routines:SSL3_ACCEPT:unsafe legacy renegotiation disabled
[Thu Dec 06 09:14:25 2012] [error] [client] request body exceeds maximum size (131072) for SSL buffer
[Thu Dec 06 09:14:25 2012] [error] [client] could not buffer message body to allow SSL renegotiation to proceed

But even using the SSLRenegBufferSize directive the user still have the bug (it's pure random). The big problem is I can't even reproduce the bug. The http client (browser) may be the difference between me and the user, I only have Firefox 17 under Linux, and I am collecting information from the user.

The optional value for SSLVerifyClient is needed since it allow our software to handle when a user don't have his certificate, or when a certificate is expired. Otherwise the browser just show a technical error page, not suitable to our users.

share|improve this question

marked as duplicate by RobM, longneck, Tom O'Connor, Ward, Khaled Dec 29 '12 at 7:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

you already tried the solutions of this link ?… – 0wn3r Dec 26 '12 at 16:47
No, I have not found it, but I try it right now. Thanks. – Cédric Girard Dec 27 '12 at 8:53
Own3r, your tip is good and the situation get better. The problem still occurs, but we can retry the upload and it work. Thanks. It's a brain damage problem! I will flag your answer if you post it. – Cédric Girard Dec 27 '12 at 11:24
up vote 1 down vote accepted

The problem occurs randomly because this happens only when renegotiation is needed, by the way this post should contain the answer to the question
Request Entity Too Large error while uploading files of more than 128KB over SSL

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.