Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install the Azure 1.8 SDK for Visual Studio 2012 via webpicmd.exe as shown on the SDK download page:

The command I'm trying to run is

webpicmd /install /products:WindowsAzureToolsVS2012_1_8 /accepteula

When I do so I get the message

The following products are not available on this machine or already installed: WindowsAzureToolsVS2012_1_8

If I use the Web Platform Installer GUI I am able to install the SDK but I'd like to be able to automate it. Any ideas what I'm doing wrong?

share|improve this question

The command closest to what you are probably looking for is this:

webpicmd /Install /Products:WindowsAzureToolsVS2012 /AcceptEula /Log:log.txt

However you say that you want 1.8 SDK, but the command will install Visual Studio tools, not SDK and v1.8 is latest, so in future you might get higher version. From what I know and what I tried, there is currently no way of explicitly choosing version 1.8 for VS2012.

share|improve this answer
Is the SDK not a dependency of the Azure tools? I would expect it to be automatically installed when installing the tools. – Evan Mar 20 '13 at 15:23

Do you have the latest version of the web platform installer? Or is the correct version of webpicmd.exe being used when you run the command.

I just ran into this problem and found it was because I installed an older version of webpicmd.exe

share|improve this answer
I'm installing web platform installer via Chocolatey. It's possible that it is installing an old version, I'll check that. – Evan Mar 28 '13 at 15:24
up vote 0 down vote accepted

I figured out the IDs that work for azure sdk 1.8 and 2.0 currently.

The 1.8 id is /products:VWDOrVs11AzurePack_1_8_1

The 2.0 id is /products:vwdorvs11azurepack

Both of those worked for me using the latest web platform installer.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.