Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to setup my own virtual host on Debian Squeeze and I think I have done the setup as per the documentation and have gone through a number of questions and answers. Everything seems to suggest I have done everything right. However, I see that it always serves only the default site. As per another related question I checked my setup as follows:

$ (source /etc/apache2/envvars && /usr/sbin/apache2 -S)
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80                   is a NameVirtualHost
     default server hms01san.lan (/etc/apache2/sites-enabled/000-default:1)
     port 80 namevhost hms01san.lan (/etc/apache2/sites-enabled/000-default:1)

Syntax OK

I tried changing the '*:80' in the NameVirtualHost as well as the VirtualHost entries to a simple '*', but get the same issue.

Would appreciate any help in getting this fixed.

Update: I get this issue only when using the external DNS redirect of my domain setting, works fine when I setup the host name locally in my /etc/hosts.

share|improve this question
Please provide output of: cat /etc/apache2/ports.conf; for i in /etc/apache2/sites-enabled/*; do echo "=== $i ==="; cat "$i"; done. What is the result of DNS query for the domain in question using external DNS? What do you add to /etc/hosts? – 0xFF Dec 26 '12 at 21:20
It's all resolved now. Thanks for taking a look, 0xFF. The issue was with the settings of my domain. I had to update the DNS settings of my domain instead of the http redirect that I had setup. – Amar Dec 27 '12 at 16:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.