Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed Apache, PHP5, MySQL and Webmin on a vps. I host my website on that.

I completely reinstalled whole VPS with fresh installation of Postfix and Dovecot. But Dovecot fails to start, so Roundcube can't connect.

I installed Postfix, Apache, MySQL, PHPMyAdmin, Dovecot using this source: http://www.howtoforge.com/perfect-server-debian-squeeze-with-bind-and-dovecot-ispconfig

Need some guidance to bring Dovecot up.

share|improve this question
    
(1) Do you know your mysql root password? (2) Post grep -i dovecot /var/log/syslog –  John Siu Dec 26 '12 at 22:06
    
Yes i know it. But if i properly understand this log, im not allowed to use root account for loggingin in dovecot. IM going to try with another account. Log is here: pastebin.com/JvaqJZM6 –  xZero Dec 26 '12 at 22:13
    
Postfix is also down. Dec 27 04:33:31 server4 postfix/master[719]: fatal: bind 0.0.0.0 port 25: Address already in use Dec 27 04:33:36 server4 postfix/postqueue[822]: warning: Mail system is down -- accessing queue directly 2 - I tried with new created user account to login on roundcube but it says authentication failed. Dovecot: Dec 27 04:36:56 server4 dovecot: imap-login: Aborted login (tried to use unsupported auth mechanism): method=PLAIN, rip=94.249.208.215, lip=94.249.208.215, secured –  xZero Dec 26 '12 at 22:36
    
Post output of "pstree ". You may have exim4 running. "apt-get purge exim4" –  John Siu Dec 26 '12 at 22:41
    
pastebin.com/ueRvjHtP –  xZero Dec 26 '12 at 23:12

1 Answer 1

up vote 1 down vote accepted

To use roundcube and shown as test@domain.com, you should login roundcube with your full email address test@domain.com. If you forget to do so, it will append the full machine name.

Update

In roundcube config, setup the following

$rcmail_config['username_domain'] = '<the-domain-name>';

Go through your webmin interface and learn how to put it in. There is webmin module for roundcube.

share|improve this answer
    
It doesn't work at all. Dec 28 09:01:41 server4 dovecot: imap-login: Aborted login (auth failed, 1 attempts): user=<example@mydomain.com>, method=PLAIN, rip=XX.XXX.XXX.215, lip=XX.XXX.XXX.215, secured –  xZero Dec 28 '12 at 3:01
1  
Updated answer. If it is configure correctly, login roundcube without the domain portion. –  John Siu Dec 28 '12 at 3:15
    
Thanks it works now :) –  xZero Jan 3 '13 at 12:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.