Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a strange problem, and I am not very familiar with Mac OSX so I am coming here for help.

I have two Mac Minis on a network 192.168.1.*

Mac Mini 1 = Mac Mini 2 =

My workstation is on 10.1.10.* VPN on 192.168.2.*

About once every two days or so the Mac Mini 2 stops accepting ssh connections from any network other than it's own. I cannot ping it or anything from my workstation, but if I ssh into Mac Mini 1 and then ssh to Mac mini 2 from there it works and magically I can then ping and ssh from my workstation.

the sshd-config is the same on the two minis. I thought the machines were identical, but I just discovered that Mac Mini 1 is running OSX 10.7.4 and Mini 2 is running OSX 10.7.2. Could that be a clue?

Any ideas?

Thanks for taking the time to read and respond!

share|improve this question

closed as off topic by Mathias R. Jessen, mfinni, Ward, mdpc, gWaldo Dec 27 '12 at 17:01

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Is Mac Mini 1 going to sleep? Apple plays some tricks with Bonjour sleep proxies to wake sleeping computers when they're accessed over the network, but that might not work over the VPN connection (but would work from another Mac on the same network, and then once it was awake it'd work over VPN as well). – Gordon Davisson Dec 27 '12 at 7:53
Need more info. (1) Netmask of and (2) How is vpn setup? (OS X VPN service? VPN connection is NAT/Bridge/Route to LAN?) – John Siu Dec 27 '12 at 16:25
Thanks for the help guys! I figured out how to enable vnc from the cmd line, logged in and started rooting around and I found that I missed a power setting (or it got reset). The mini was set to go to sleep (facepalm), but set allow "wake on network"(handy). Thanks again! – lysdexic Dec 27 '12 at 16:40
up vote 0 down vote accepted

See my comment above, the darn thing was set to go to sleep, not sure how I could have missed that...

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.