Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have CentOS server installed inside vmware for testing puprose. For some strange reason When it comes up it won't get IP address properly

So, I have to manually use 'ifdown' and 'dhclient' every time it comes up. I only do have problem with internet running interfaces and not any other interface.

share|improve this question
1  
Do you have the latest VMWare tools installed in the CentOS vm? –  AngerClown Dec 27 '12 at 3:45
add comment

1 Answer

Is this CentOS 6? If so I got burned by this one as well. Check out the official CentOS 6 FAQ.

The issue is that NetworkManager is now responsible for the eth0 device and by default it's disabled. During installation you can configure eth0 so that it will start up automatically, but the default is that it doesn't.

If you need to configure this after you've setup the system you can follow the steps in the FAQ which tell you exactly how to setup the eth0.

The nuts of the fix are that you need to edit this eth0 configuration file, /etc/sysconfig/network-scripts/ifcfg-eth0, and make sure that the ONBOOT line is enabled, i.e., ONBOOT="yes".

Here's a couple of screenshots of where to configure this during the CentOS installation. I totally missed it the first couple of times.

Installation, configure networking for ONBOOT 1/3

                 Installation, configure networking for ONBOOT 2/3

                  Installation, configure networking for ONBOOT 3/3

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.