Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Our Shoretel 230 phones are not picking up time service correctly and thus, the time on the display is wrong. When I go to the diagnostics of the phone, they are using a wrong time server (old).

Here is the top scope of my dhcpd.conf. The instructions for Shoretel only are given for using Windows Server DHCP server - but I have found others online that have used dhcpd for use with Shoretel phones. The phones pick up the ftp server just fine - but don't seem to grab the NTP server. Any clues below to what I might have configured wrong?

ddns-update-style none;
deny bootp;
authoritative;
option wpad code 252 = text;
option ntp-servers 199.4.29.166, 38.229.71.1, 204.235.61.9, 72.20.40.62;
option shoretel-server code 156 = string;
option shoretel-server "ftpservers=192.168.**.***";
share|improve this question
    
What have you done to verify the phones are not picking up the ntp servers? Can you actually see a non-blank setting in the phone for an NTP server? Do you have a regular host you can configure for dhcp, so you can cross-check that something is picking up the ntp servers correctly? – dafydd Dec 27 '12 at 17:23
    
The phones have a key combo that allows you to see their config (MUTE BUTTON, I-N-F-O). When I do this it has a non blank NTP server (an old one that used to work). How would I check a regular host to see if it picked up the NTP server? – bsigrist Dec 27 '12 at 20:58
    
Have you tried removing a phone's DHCP registration from your DHCP server and having the phone pull in a fresh DHCP registration? Also have you tried factory resetting one of phones just to see if the correct NTP servers get pulled in? – carpetflyer Feb 26 '13 at 19:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.