Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I cannot ping the Windows 2008 R2 server by hostname from Windows XP Home machines, but I can ping it from Windows 7 Ultimate machines. I already disabled ipv6. I need to access a shared folder: \server\a

All computers are on the same local network, there is no DNS in use. Just every computer in the same Workgroup.

Any ideas why?

EDITED: I have heard that the problem could be that different systems chose different Master browsers.

share|improve this question
Can you ping it by IP address? – MDMarra Dec 27 '12 at 18:40
yes i can ping it by IP adress – PaN1C_Showt1Me Dec 27 '12 at 18:43
perhaps another topic is, the server has a dynamic IP provided by local DHCP. As all computers should only access WebServices on server/Services.asmx I do not know if it would not be a problem – PaN1C_Showt1Me Dec 27 '12 at 18:45
If you can ping it via IP address. You should flushdns (ipconfig /flushdns) and see if it works now. – davidb Dec 27 '12 at 18:46
no, cannot find the hostname. But it is on the LAN with no DNS server or anything. – PaN1C_Showt1Me Dec 27 '12 at 18:47

Judging by your comments that you aren't using DNS, your problem is NetBIOS name resolution.

NetBIOS over TCP/IP is disabled in Windows Server 2008 R2 by default, however it is the only way for XP to handle local name resolution without a DNS server. This problem does not exist for newer OSes on your network, because they use LLMNR/WS-Discovery, and not NetBIOS.

You can enable the NetBIOS responder in the WINS section of the IPv4 network settings: enter image description here

You also need to make sure that the Computer Browser service is started and that Windows Firewall is allowing inbound IPv4 NetBIOS traffic.

share|improve this answer
I have enabled it but still no luck :/ – PaN1C_Showt1Me Dec 27 '12 at 18:53
See my last edit. You're also going to need to make sure that the computer browser service is started and that Windows Firewall (if enabled) is configured to allow NetBIOS traffic. – MDMarra Dec 27 '12 at 18:55
What do you recommend as the most elegant way of losing this problem? Should I make the computer a wins server or some other who would care of translating names to ip addresses? Or a domain controller? Or it is an overkill for this purpose – PaN1C_Showt1Me Dec 27 '12 at 19:40
Use DNS. WINS is a dying (dead) technology. – MDMarra Dec 28 '12 at 15:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.