Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.
postconf -d | grep message_size_limit

Shows:

message_size_limit = 10240000

This limit was not set in /etc/postfix/main.cf so I assume its a default?

I added message_size_limit = 31457280 to my /etc/postfix/main.cf and restarted postfix. But I still get message_size_limit = 10240000 from postconf -d | grep message_size_limit. It's not accepting my change. why?

share|improve this question
    
Try do hard reload using /etc/init.d.postfix stop ; /etc/init.d/postfix start. You can try to check, if postfix use the same config file by postconf | grep config_directory –  Jan Marek Dec 27 '12 at 21:43
    
The config directory is correct, stopping and starting manually has no change (its service postfix stop on this system), no errors in mail log. –  Nick Dec 27 '12 at 21:46

1 Answer 1

up vote 1 down vote accepted

From the man postconf:

-d    Print default parameter settings instead of actual settings.

You have do not use -d parameter in the invocation of postconf utility.

share|improve this answer
    
In other words, I'm an idiot. –  Nick Dec 27 '12 at 21:58
    
No, but sometimes people don't see everythink, me is one of them. –  Jan Marek Dec 28 '12 at 9:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.