Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is what I tried but it doesn't work :

  1. Connect with SSH
  2. # /etc/init.d/usbarbitrator stop
  3. # fdisk -l |grep Disk

    Disk /dev/disks/mpx.vmhba40:C0:T0:L0: 4022 MB, 4022337024 bytes

  4. # ls /dev/disks/mpx.vmhba40:C0:T0:L0*

    /dev/disks/mpx.vmhba40:C0:T0:L0 /dev/disks/mpx.vmhba40:C0:T0:L0:4

  5. # mkdir /mnt/usb

  6. # mount /dev/disks/mpx.vmhba40:C0:T0:L0 /mnt/usb

    mount: mounting /dev/disks/mpx.vmhba40:C0:T0:L0 on /mnt/usb failed: No such file or directory

  7. Also tried with /dev/disks/mpx.vmhba40:C0:T0:L0:4, with /mnt/usb/, always the same error message.

  8. Then I checked # ls -l /vmfs/volumes, but it wasn't there either

The version of ESXi is 4.1... USB Key is FAT32 as far as I know.

Any help or advice would be appreciated !

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

Looking at this VMware KB article it looks like it should be a FAT 16 formatted USB drive

The USB key or disk device media is formatted with a FAT16 partition and is of maximum size 2GB

Update: Looking at this blog post the drive would need to be FAT16, Which would make sense to me as VMware made ESXi as small footprint they can which would mean not including unneeded things in the kernel such as file system drivers.

share|improve this answer
    
Yes I saw that article, but it wasn't clear if this statement was a problem or a requirement. –  db_ch Dec 29 '12 at 21:37
    
Looks to me like a requirement. –  Epaphus Dec 29 '12 at 21:52
    
Updated answer with another article I found. –  Epaphus Dec 29 '12 at 21:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.