Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Ok so this may be something really obvious that I am missing out but hopefully somebody will be able to spot what I have done wrong or suggest some further steps.

I am running a debian squeeze server on our domain network and when in the office on the same network as the server I can connect to the FTP and SSH on to the server without an issue.

However FTP and SSH connections over a VPN onto the network (to a windows server) appear to be timing out. Putty is reporting

Network Error: Connection timed out

I have removed iptables to see if that made any difference but still no luck. While telneting on to either port 21 or 22 of the server I get the response

Could not open connection to the host, on port 21: Connect Failed

I have even tried to turn off the laptop firewall to see if it is a local issue but port 80 i am still able to access (can also ping - response approx 70ms).

It only seems to be a recent problem but I haven't made any changes to the system since it worked (that I can remember).

Any help would be appreciated

share|improve this question
    
What if you traceroute/tracepath the host? Does the traffic try to go through the proper routes and interfaces? –  Halfgaar Dec 28 '12 at 18:31
    
Running a traceroute from my windows 7 laptop over the VPN the route is going to the DC (albeit through the correct hostname and wrong IP - possibly the problem?) and then to our webserver –  gareth89 Dec 28 '12 at 22:29
    
Do you try to connect to the server on IP or host name? Maybe it's a DNS issue. –  Halfgaar Dec 29 '12 at 9:30
    
have tried both however it now appears to be the windows server causing the issue. doing a traceroute to the DNS/DHCP server gives the correct IP, but doing a traceroute to any other network device is giving the wrong IP which is an IP reserved for RAS –  gareth89 Dec 29 '12 at 12:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.