Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Since today Debian gives an error: ifup: couldn't read interfaces file "/etc/network/interfaces"

If I look up the interfaces file I see the following:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dchp

allow-hotplug eth1
iface eth1 inet dchp

I'm running Debian in a Virtual Box; eth0 is a NAT and eth1 is a host-only adapter I also tried it with an ethernet cable plugged in, but that didn't make a change.

How can I get rid of this error?

Thank you in advance,

Remco

share|improve this question
    
Can you put strace -fv ifup eth0 to pastebin.com or a similar site? –  ott-- Dec 28 '12 at 16:05
add comment

1 Answer

You'll probably kick yourself, but you've got the same typo on two lines. It should be iface eth0 inet dhcp not dchp.

ifup and ifdown will break if they can't parse the file.

share|improve this answer
    
Thank you very much, that worked fine! –  user1879242 Dec 29 '12 at 10:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.