Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I believed I've downloaded and updated the EPEL rpm but I can't install php-pecl-memcached.. I'm very new to this, any help is appreciated.

#rpm -Uvh epel-release-6-8.noarch.rpm warning: epel-release-6-8.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID
0608b895: NOKEY Preparing...               
########################################### [100%]
        package epel-release-6-8.noarch is already installed

# yum update Loaded plugins: fastestmirror, security Loading mirror speeds from cached hostfile  * base: mirror.us.leaseweb.net  * epel:
mirror.symnds.com  * extras: mirror.ash.fastserv.com  * updates:
mirror.vcu.edu Setting up Update Process No Packages marked for Update


#yum install php-pecl-memcached Loaded plugins: fastestmirror, security Loading mirror speeds from cached hostfile  * base:
mirror.us.leaseweb.net  * epel: mirror.symnds.com  * extras:
mirror.ash.fastserv.com  * updates: mirror.vcu.edu Setting up Install
Process No package php-pecl-memcached available. Error: Nothing to do
share|improve this question
1  
do a yum list all | grep php-pecl-memcached to see if it's available. –  slm Dec 29 '12 at 4:10
    
nothing appeared. –  Jeff Dec 29 '12 at 4:36
1  
Can you please try this command # yum list | grep -i php | grep -i pecl | grep -i memcache and give me the output –  GeekRide Dec 29 '12 at 4:36
    
no output again –  Jeff Dec 29 '12 at 4:53
    
That means that the yum repos you have installed do not list this package as being available. –  slm Dec 29 '12 at 5:27
add comment

3 Answers

up vote 6 down vote accepted

You have almost certainly mistakenly excluded some packages with yum's exclude option in your yum.conf or a file which it includes. For instance you may have:

exclude=php*

This would prevent any package whose name begins with PHP from ever being shown to you.

To fix the problem, remove the exclusion from your yum configuration.

(This was probably done as a misguided attempt to version-lock the PHP packages. Use the yum versionlock plugin to accomplish this instead.)

share|improve this answer
1  
Thank you! Removed php exlusion and it works! I'm unsure why php was excluded since I didn't do any modifications to the file. Nonetheless it works now. TY Happy Holidays everyone –  Jeff Dec 29 '12 at 5:30
add comment

Expanding on @Michael Hamptons answer. You could have debugged this issue like this as well.

1. First confirm same system as OP

% uname -a
Linux data01 2.6.32-279.14.1.el6.x86_64 #1 SMP Tue Nov 6 23:43:09 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
% cat /etc/redhat-release 
CentOS release 6.3 (Final)

2. Show yum cmds when there is no exclude=php* present in /etc/yum.conf

% repoquery *pecl* --location
http://eq-centosrepo.hopto.org/6.3/os/x86_64/Packages/php-pecl-apc-3.1.9-2.el6.x86_64.rpm
http://eq-centosrepo.hopto.org/6.3/os/x86_64/Packages/php-pecl-apc-devel-3.1.9-2.el6.x86_64.rpm
http://eq-centosrepo.hopto.org/6.3/os/x86_64/Packages/php-pecl-memcache-3.0.5-4.el6.x86_64.rpm

3. Show repos

% yum repolist
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: yum.singlehop.com
 * extras: mirror.anl.gov
 * updates: mirrors.seas.harvard.edu
repo id                                                  repo name                                                            status
base                                                     CentOS-6 - Base                                                      6,346
extras                                                   CentOS-6 - Extras                                                       17
updates                                                  CentOS-6 - Updates                                                   1,048
repolist: 7,411

4. Add an exclude=php* to /etc/yum.conf

% vim /etc/yum.conf
...
...
exclude=php*
...

5. Confirm php* packages are excluded

# with repoquery

% repoquery *pecl* --location
% 

# with yum

% yum list all php-pecl*
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: yum.singlehop.com
 * extras: mirror.anl.gov
 * updates: mirrors.seas.harvard.edu
Error: No matching Packages to list

6. Tell yum to ignore the excludes using --disableexcludes=all switch

% yum list all php-pecl* --disableexcludes=all
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: yum.singlehop.com
 * extras: mirror.anl.gov
 * updates: mirrors.seas.harvard.edu
Available Packages
php-pecl-apc.x86_64                                                    3.1.9-2.el6                                              base
php-pecl-apc-devel.x86_64                                              3.1.9-2.el6                                              base
php-pecl-memcache.x86_64                                               3.0.5-4.el6                                              base
share|improve this answer
add comment

First, check to see if you have the package installed already...

# yum list installed php-pecl-memcached.x86_64

or

# rpm -qi php-pecl-memcached

That will give you an indication of the current state of the system. From here, it looks like you already have this installed... but those two commands will help you check for sure.

-- edit --

The yum repolist output shows the EPEL repository enabled, as well as the Powerstack repo. These two have similar packages. In Powerstack, which is probably handling your PHP and Apache, you need to:

yum install php-pecl-memcache

The package has a slightly different name than in EPEL. Try that.

share|improve this answer
    
Packages aren't installed. First output Error: No matching Packages to list Second output package php-pecl-memcached is not installed thanks! –  Jeff Dec 29 '12 at 4:02
    
Run a yum clean all and try yum install php-pecl-memcached again. –  ewwhite Dec 29 '12 at 4:18
    
cleaned successfully, tried again to install but end result was Setting up Install Process No package php-pecl-memcached available. Error: Nothing to do –  Jeff Dec 29 '12 at 4:22
    
What OS and version are you using? –  ewwhite Dec 29 '12 at 4:39
    
CentOS release 6.3 (Final) –  Jeff Dec 29 '12 at 4:47
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.