Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've just installed Munin for the first time in around twelve months, and I've hit a familiar error.

I remember from last year that there is an oddity where Munin wants to keep its html files in /var/cache/munin/www, rather than the usual /var/www/munin. I seem to remember being able to change the config files accordingly, and force the app to put the files in the right place, and everything worked fine.

Tonight though, I managed to make Munin write the files to the correct directory, but for some reason Apache isn't pointing to them correctly.

For example, the monitoring should be available at website.com/munin - website.com is in /var/www - but for some reason Apache keeps pointing to where Munin originally wanted to put the files. If I copy everything back to /var/cache/munin/www, it works.

Is there an Apache setting I have missed anywhere? I'm not sure where it could be, but something is obviously stopping Apache from serving website.com/munin from /var/www/munin.

All that make any sense?

Cheers.

share|improve this question
    
Good first question! –  slm Dec 29 '12 at 6:21
    
Check the document root dir for munin in apache config file where webserver is pointing to. Also check the apache logs for more details and permission for apache user on munin dir in /var/www. –  Somesh Dec 29 '12 at 6:24
    
Is /var/cache/munin/www used because you installed munin 2? –  Eric DANNIELOU Dec 29 '12 at 10:07
add comment

1 Answer

Look in Apache's config files. The main file is located here: /etc/httpd/conf/httpd.conf There should also be a bunch of files under here: /etc/httpd/conf.d/. One of them in the 2nd location may even be called munin.conf or some such.

Look through these files and you'll see a section that is telling Apache to look in the /var/cache/munin/www.

Probably something like this:

<Directory "/var/cache/munin/www">
    Options Indexes FollowSymLinks
    Order allow,deny
    Allow from all
</Directory>

and also some sort of Location or AliasMatch lines like this:

AliasMatch ^/munin(.*)?$ "/var/cache/www/munin/www$1"

You can either change these around to suit your needs or put the configuration in Munin back so that it writes the files to the directory that Apache is expecting it. I'd do the latter.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.