Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My updatesite.nsf has the following features:

Domino Access Services (DAS)                                          8.5.3.20121217-1354
Domino Wink                                                           8.5.3.20121217-1354
XPages Extension Library Feature                                      8.5.3.20121217-1354
Extended Components Library for XPages Extension Feature              8.5.3.20121217-1354
XPages Extension Library Designer Source Feature                      8.5.3.20121217-1354
XPages Extension Library Designer Feature                             8.5.3.20121217-1354
XPages Extension Library Source Feature                               8.5.3.20121217-1354
Extended Components Library for XPages Extension Feature              8.5.3.20121217-1354
Apache Wink                                                           1.1.2.20121217-1354

In notes.ini I have this:

OSGI_HTTP_DYNAMIC_BUNDLES=admin/updatesite.nsf

When I restart HTTP I get this message:

HTTP JVM: CLFAD0330I: NSF Based plugins are being installed in the OSGi runtime. For more information please consult the log

Which log does "please consult the log" refer to?

When I issue console command

tell http osgi ss com.ibm.xsp.extlib

I get this:

10 INSTALLED   com.ibm.xsp.extlib.designer_8.5.3.20121217-1354
11 RESOLVED    com.ibm.xsp.extlib.feature.source_8.5.3.20121217-1354
12 INSTALLED   com.ibm.xsp.extlib.designer.tooling_8.5.3.20121217-1354
13 INSTALLED   com.ibm.xsp.extlib.designer.xspprops_8.5.3.20121217-1354
14 RESOLVED    com.ibm.xsp.extlib.designer.tooling.feature.source_8.5.3.20121217-1354
15 RESOLVED    com.ibm.xsp.extlibx.source_8.5.3.20121217-1354
142 RESOLVED    com.ibm.xsp.extlib.controls.nl1_8.5.3.20111208-0717
             Master=145
143 RESOLVED    com.ibm.xsp.extlib.controls.nl2_8.5.3.20111208-0717
             Master=145
144 RESOLVED    com.ibm.xsp.extlib.controls.nl3_8.5.3.20111208-0717
             Master=145
145 <<LAZY>>    com.ibm.xsp.extlib.controls_8.5.3.20111208-0717
             Fragments=142, 143, 144
146 RESOLVED    com.ibm.xsp.extlib.core.nl1_8.5.3.20111208-0717
             Master=149
147 RESOLVED    com.ibm.xsp.extlib.core.nl2_8.5.3.20111208-0717
             Master=149
148 RESOLVED    com.ibm.xsp.extlib.core.nl3_8.5.3.20111208-0717
             Master=149
149 <<LAZY>>    com.ibm.xsp.extlib.core_8.5.3.20111208-0717
             Fragments=146, 147, 148
150 RESOLVED    com.ibm.xsp.extlib.domino.nl1_8.5.3.20111208-0717
             Master=153
151 RESOLVED    com.ibm.xsp.extlib.domino.nl2_8.5.3.20111208-0717
             Master=153
152 RESOLVED    com.ibm.xsp.extlib.domino.nl3_8.5.3.20111208-0717
             Master=153
153 <<LAZY>>    com.ibm.xsp.extlib.domino_8.5.3.20111208-0717
             Fragments=150, 151, 152
154 RESOLVED    com.ibm.xsp.extlib.mobile.nl1_8.5.3.20111208-0717
             Master=157
155 RESOLVED    com.ibm.xsp.extlib.mobile.nl2_8.5.3.20111208-0717
             Master=157
156 RESOLVED    com.ibm.xsp.extlib.mobile.nl3_8.5.3.20111208-0717
             Master=157
157 <<LAZY>>    com.ibm.xsp.extlib.mobile_8.5.3.20111208-0717
             Fragments=154, 155, 156
158 RESOLVED    com.ibm.xsp.extlib.oneui.nl1_8.5.3.20111208-0717
             Master=161
159 RESOLVED    com.ibm.xsp.extlib.oneui.nl2_8.5.3.20111208-0717
             Master=161
160 RESOLVED    com.ibm.xsp.extlib.oneui.nl3_8.5.3.20111208-0717
             Master=161
161 <<LAZY>>    com.ibm.xsp.extlib.oneui_8.5.3.20111208-0717
             Fragments=158, 159, 160
162 <<LAZY>>    com.ibm.xsp.extlib_8.5.3.20111208-0717

None of these are active at this point. How do I know which version it uses and why are the old versions listed? When I start using XPages the old 2011 versions turn to ACTIVE state and xpagesext.nsf gives this error:

Cannot find the library "com.ibm.xsp.extlib.library" with tag version 8.5.32001, to be used by the page /Core_InPlaceDialog.xsp. The library tag version is blank.

In my understanding this indicates old ExtLib version. How do I get rid of the old versions and make the new version ACTIVE?

thanks,

  • Panu
share|improve this question

1 Answer 1

up vote 1 down vote accepted

It looks like Upgrade Pack 1 is already installed on the server. Upgrace Pack 1 is version "8.5.3.20111208-0717" (and has no extlibx components).

So you need to uninstall Upgrade Pack 1 and then use the update site method to install extension library.

share|improve this answer
1  
I must have installed it at some point although I don't remember doing so. I uninstalled it and got rid of the 2011 versions but the new ones did not activate. I found this "CLFAD0331W: NSF Based plugin contribution denied because signer does not have required access: :admin\updatesite.nsf" from error-log-0.xml. I signed the db a few times and finally realized I had to select "Actions -> Sign All Content" in UpdateSite db with Notes client. That fixed it and the lastest extlib version works now. Thanks! –  Panu Haaramo Dec 30 '12 at 14:04
    
Btw. I was expecting Admin client would show "Upgrade Pack 1" like it shows "FP3" and "HF87". –  Panu Haaramo Dec 31 '12 at 11:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.