Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have question about strange behavior of my openVPN configuration on Debian lenny. I have 2 server configs (one proto tcp-server based and one proto udp based). ISP bandwidth is 7Mbit/7Mbit.

When I uses proto tcp-server my download server rate is fine around 6,4 Mbit/s, but upload rate is about 3Mbit/s.

When I uses proto udp, my download server rate is around 3Mbit/s and upload rate around 6,4Mbit/s.

I tried to handle the MTU, MSSFIX and cipher on/off on server and client configs to synchronize rates, but without solution.


Here is TCP based SERVER config:

mode server
tls-server
port 1194
proto tcp-server

dev tap0

ifconfig 11.10.15.1 255.255.255.0
ifconfig-pool 11.10.15.2 11.10.15.20 255.255.255.0

push "route 192.168.1.0 255.255.255.0"
push "dhcp-option DNS 192.168.1.200"
push "route-gateway 11.10.15.1"
push "dhcp-option WINS 192.168.1.200"

route-up /etc/openvpn/routeup.sh

duplicate-cn
ca /etc/openvpn/ca.crt
cert /etc/openvpn/server.crt
key /etc/openvpn/server.key
dh /etc/openvpn/dh2048.pem

log-append /var/log/openvpn.log
status /var/run/vpn.status 10
user nobody
group nogroup
keepalive 10 120
comp-lzo
verb 3
script-security 3
plugin /usr/lib/openvpn/openvpn-auth-pam.so system-auth
persist-tun
persist-key
mssfix
cipher BF-CBC

Here is UDP based SERVER config:

port 1194
proto udp
dev tun0
local xx.xx.xx.xx
server 11.10.15.0 255.255.255.0

ca /etc/openvpn/ca.crt
cert /etc/openvpn/server.crt
key /etc/openvpn/server.key
dh /etc/openvpn/dh2048.pem

log-append /var/log/openvpn.log
status /var/run/vpn.status 10
user nobody
group nogroup
keepalive 10 120
comp-lzo
verb 3
duplicate-cn
script-security 3
plugin /usr/lib/openvpn/openvpn-auth-pam.so system-auth
persist-tun                     
persist-key
tun-mtu 1500
mssfix 1212
client-to-client
ifconfig-pool-persist ipp.txt

Here is TCP/UDP based windows CLIENT config:

remote xx.xx.xx.xx
--socket-flags TCP_NODELAY    
tls-client
port 1194
proto tcp-client 
#proto udp
dev tap 
#dev tun

pull
ca ca.crt
cert latis.crt
key latis.key
mute 0
comp-lzo adaptive
verb 3

resolv-retry infinite                   
nobind
persist-key                       
auth-user-pass                          
auth-nocache
script-security 2
mssfix 
cipher BF-CBC
share|improve this question

1 Answer 1

I've setup a few OpenVPN's and never had this problem, but if your running this on a VPS then this could be why your experiencing different transfer rates since even though you are in a private area of the server your still operating under generally 1 NIC and depending on traffic I'd imagine UDP and TCP to vary, UDP tends to be less reliable and data can be sent or received as corrupted and discounts do not happen that often on lag spikes, while TCP is more reliable, checks data and reports disconnects faster.

I recommend you hop over to #openvpn on irc.freenode.net on IRC using a client like Mirc, they are rather helpful in there and should be able to answer this question though I believe this is the result of a VPS server if I'm correct.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.