Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have installed request tracker v 4.0.8 and everything is working. Now I'm trying to integrate it with Active Directory 2008. I used this DOC: http://requesttracker.wikia.com/wiki/CentOS5InstallPlusSome

But unable to get it working. The RT weblogin doesn't even check for the AD server. I can't find any logs regarding to it. I have already seen a question here in serverfault regarding active directory and Rt, but it was for old version and I'm using a new version.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

try this. in your apache config place:

<Location /rt>
        AddDefaultCharset UTF-8
        SetHandler perl-script
        PerlResponseHandler RT::Mason
        Require valid-user
        AuthType Basic
        AuthName "RT Server"
        AuthBasicProvider ldap
        AuthzLDAPAuthoritative Off
        AuthLDAPBindDN "domainName\someExistingADUser"
        AuthLDAPBindPassword passwordForThatUser
        AuthLDAPURL ldap://address.of.your.domain.controller:389/ou=Users,dc=some,dc=name,dc=ofyourdomain?sAMAccountName?sub?(objectClass=*)
</Location>
<LocationMatch "/rt/NoAuth">
        Satisfy Any
        Allow from all
</LocationMatch>
<LocationMatch "/rt//REST/1.0/NoAuth">
        Satisfy Any
        Allow from all
</LocationMatch>

and in RT_SiteConfig.pm add:

Set($WebExternalAuth , 1);
Set($WebFallbackToInternalAuth , 1);
Set($WebExternalAuto , 1);

restart apache and hope for the best :]

share|improve this answer
    
Thank you. But doesn't work. Its giving 500 internal error. And can't find anything in error log. –  FELDAP Jan 2 '13 at 8:01
    
try finding out if it's apache giving you 500s or rt - reconfigure things and set ldap-based authentication on some static file or folder not related to rt. –  pQd Jan 2 '13 at 8:41
    
No. Even RT doesn't send the error. I checked in RT logs too. I don't understand what you mean by setting up static file. –  FELDAP Jan 2 '13 at 8:53
    
try to use ldap authentication within apache for a static folder; forget about rt at this stage and try to see if ldap authentication in apache works. if it does not - it's apache configs you need to check; if it does - it's time to look more into details of rt. –  pQd Jan 2 '13 at 9:22
    
You are right. I made a test file and checked. Its shows the same error 500. –  FELDAP Jan 2 '13 at 11:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.