Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

What is jbd2/dm-0-8 and why It is consuming all my I/O usage and causing I/O wait?

Is there anyway to disable this?

Bonnie++ results: http://pastebin.com/iQCWP1qp

$ sudo hdparm -t /dev/sda1

/dev/sda1:
 Timing buffered disk reads: 108 MB in  3.02 seconds =  35.71 MB/sec
share|improve this question
1  
Replace the slow and possibly failing disks with faster disks. –  Michael Hampton Jan 2 '13 at 16:11
    
Thanks, as you mentioned about slow disks I attached my bonnie++ results. Is this kind of a slow disk? –  Super Mario Jan 2 '13 at 18:38
    
Sheesh, the three year old drive on my desktop is faster than that. –  Michael Hampton Jan 2 '13 at 18:45
    
Oh, even the hdparm result (added to my question) is bad enough to cause this? –  Super Mario Jan 2 '13 at 18:48

2 Answers 2

up vote 2 down vote accepted

jbd is the "journaling block device". dm-0-08 indicates a device mapped by device mapper. It just indicates that you are doing IO and it is being flushed out to disk properly. It is not by itself a source of IO.

Here is vague advice based on the vagueness of the question: If you need less iowait time, your machine needs to do less work, work more efficiently, or have more io resources to do work with.

share|improve this answer
    
Thanks, I tweaked settings as much as I could but still no change. I also added my bonnie++ results. I hope that might help if it's because slow disks. –  Super Mario Jan 2 '13 at 18:40

Was the filesystem recently created? Is there any process named ext4lazyinit?

Then just wait as it inits (prepares, formats) the filesystem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.