Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The motherboard of my server (Ubuntu 8.04) died, so I replaced the motherboard, CPU, and RAM. Now I cannot get the server working on the network as it was configured.

The network is configured without DHCP.

The router IP is 10.10.10.1. The server is 10.10.10.10.

Contents of /etc/network/interfaces:

auto eth0
iface eth0 inet static
    address 10.10.10.10
    netmask 255.255.255.0
    gateway 10.10.10.1

Pinging the router (ping 10.10.10.1) results in:

PING 10.10.10.1 (10.10.10.1) 56(84) bytes of data.
From 10.10.10.10 icmp_seq=1 Destination Host Unreachable
From 10.10.10.10 icmp_seq=2 Destination Host Unreachable
...

The result of ifconfig eth0:

eth0     Link encap:Ethernet  HWaddr  90:2b:34:a5:c9:af
         inet addr:10.10.10.10 Bcast: 10.10.10.255  Mask: 255.255.255.0
         inet6 addr: fe80... ( skipped typing this )
         UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
         RX packets:0 errors:0 dropped:0 overrruns: 0 frame:0
         TX packets:446 errors:0 dropped:0 overrruns: 0 carrier:0
         collisions: 0 txqueuelen:1000
         RX bytes:o (0.0 B)  TX bytes:32324 (31.5kb)
         Interrupt:220 Base address:0xa00

The result of route:

Kernel IP routing table
Destination    Gateway         Genmask                Flags   Metric   Ref   Use   iFace
10.10.10.0     *               255.255.255.0          U       0        0       0   eth0
link-local     *               255.255.0.0            U       1000     0       0   eth0
default        10.10.10.1      0.0.0.0                UG      100      0       0   eth0

(Note: The first two results appear immediately. The last line (default route) appears after about 20 seconds. If I do route -n all results show immediately.)

The result of iptables -L shows that there are no iptables entries.

The contents of /etc/hostname:

Server

The contents of /etc/hosts:

127.0.0.1        localhost.localdomain localhost
10.10.10.10      Server.localdomain Server

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

Result of mii-tool:

SIOCGMIIPHY on `eth0` failed: Operation not supported
SIOCGMIIPHY on `eth1` failed: Operation not supported
SIOCGMIIPHY on `eth2` failed: Operation not supported
SIOCGMIIPHY on `eth3` failed: Operation not supported
SIOCGMIIPHY on `eth4` failed: Operation not supported
SIOCGMIIPHY on `eth5` failed: Operation not supported
SIOCGMIIPHY on `eth6` failed: Operation not supported
SIOCGMIIPHY on `eth7` failed: Operation not supported
no MII interfaces found

Result of sudo mii-tool:

SIOCGMIIPHY on `eth0` failed: Operation not supported
no MII interfaces found

Result of arp -a:

? (10.10.10.1) at <incomplete> on eth0

Result of dmesg | grep eth0:

[    22.188268] eth0: RTL8169 at 0xf8888000, 90:2b:34:a5:c9:af, XID 2c900800 IRQ 220
[    41.919804] r8169: eth0: link up

I have disabled IPv6 as described here because dmesg was complaining:

eth0: no IPv6 routers present

I have tried a different network cable and router port. Other computers on the network are functioning fine (they also have static IPs in the 10.10.10.x range).

Initially the network device was named eth2. I deleted /etc/udev/rules.d/70-persistent-net.rules which was successfully regenerated and the new NIC was left with the desired eth0 name. Thanks for the suggestion, Heis Spiter.

Any ideas would be a great help. Thank you!

share|improve this question
add comment

2 Answers

Is the network card you are using integrated in the motherboard?

So, has it been replaced?

If yes, check you udev net rules: /etc/udev/rules.d/70-persistent-net.rules. You might need to update your network cards naming. Removing the old network card and switching the new as eth0. The network cards are identified by their MAC address.

share|improve this answer
    
I already did that in order to achieve eth0 (which was the name of the previous onboard NIC.) Excellent suggestion though - thanks. –  doctororange Jan 2 '13 at 12:04
    
Not sure it will really help, but, what if you try to pointopoint to your gateway in network config? –  Heis Spiter Jan 2 '13 at 13:01
    
Tried that (specified network and gateway in /etc/network/interfaces) too. No luck. Keep up the suggestions though - you're sure to get it sooner or later! :) –  doctororange Jan 2 '13 at 13:24
add comment
up vote 0 down vote accepted

Removing the old r8169 driver and installing the latest r8168 did the trick.

Cheers.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.