Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Trying to install esxi on a Dell R210 II. This is an older machine and as such has Perc S300 controller. Apparently, this controller is only compatible with windows systems and there is no way to install anything else while this controller is in play.

Can I bypass the controller altogether? I tried changing the SATA setting in BIOS to disabled, and to ATA but I can not get the esxi installer to see the disks. I've also tried disconnecting the disks from the controller and plugging them straight into the board but every boot, I still see the perc card doing its thing.

So, is it at all possible to bypass this controller and just use the 2 disks normally? Or do I have to upgrade the controller?

Thanks.

share|improve this question
add comment

2 Answers

I know that these Dell PERC controllers are a pain in terms of "standard" driver availability. I have run into this problem recently in attempting to perform crash restoration on a Win 7 Pro/64 box. Your best bet is to contact Dell as they might even have drivers (or an ESXi implementation) that would work and see the disks.

If I recall, there IS someway of adding drivers for ESXi ...the last company I worked for did it for a 10GByte Ethernet card....it was a pain but it could be done.

share|improve this answer
    
Everything I've read so far speaks to it being "impossible". People had dell ship out new controller (PERC6i); people even just trying to get a *nix distro have had no luck. The Perc S300 is not listed on Vmware's HCL, so I doubt anything will be happening until I toss the s300. Thanks! –  stormdrain Jan 2 '13 at 22:07
    
Still worth a shot to talk with Dell however! –  mdpc Jan 2 '13 at 22:13
add comment
up vote 0 down vote accepted

In order to get the machine to recognize the disk sans perc, I had to completely remove the card.

Once the card was removed and the disks plugged directly into the board at SATA_A and SATA_B, I set the SATA mode in BIOS to ATA and set disk 0 and 1 to AUTO. At this point, the disks are visible to esxi installer and I was able to install and boot into esxi.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.