Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We've recently acquired a Dell PowerEdge r420 server (2 NICs). After installing the OS (Windows Server 2008 R2), we've installed SQL Server 2008 and IIS. Now we have a public IP given to us by the ISP. The aim is to make this a public facing server.

I'd like to know how to assign the public IP to this server. One NIC has been given a private IP for internal access.

Directly assigning the public IP to the other NIC doesn't work. Question is do I need to configure NAT and RRAS. Most of my search online leads to these results.

On a separate note: ping was disabled by deafult which I enabled using "netsh firewall set icmpsetting 8". Now I can ping the server internally. But while assigning the public IP to the second NIC, it can't be pinged from outside. Is there some other service which needs to be enabled?

share|improve this question
    
What is your router situation? –  EEAA Jan 3 '13 at 5:27
    
@EEAA - At the moment, the server's directly connected to the ISP's modem. After testing, it'll be going behind a firewall(Fortigate100a) –  i.h4d35 Jan 3 '13 at 5:29
1  
You said the server is directly connected to the ISP modem. But is this a modem or a router? And how is the server connected to it? How is the modem configured? You really should ask your ISP here. –  Massimo Jan 3 '13 at 5:36
    
Sorry for the stupid comment, but these things can get overlooked sometimes: are the NICs connected correctly? ie. NIC for external network should go into your ISP's router modem and NIC for internal to your internal network switch. –  Gnudiff Jan 3 '13 at 10:34
    
@Massimo - Sorry, I meant ISP's Router. The server is directly connected to it, I can access the internet from the server but when I ping tht IP from outside, I get no response and I also cannot access tht IP using Remote Desktop. Are there any other services enabled? –  i.h4d35 Jan 4 '13 at 6:02

1 Answer 1

up vote 3 down vote accepted

Assign your IP to the external nic and make sure only the external nic has a default gateway assigned. The internal nic should only have an IP assigned, no default gateway, or your routing will be broken.

You can check that the default route 0.0.0.0 is going over the external nic to the correct default gateway by typing "route print" in a cmd or powershell prompt.

You don't need to install the RRAS role or enable NAT or anything on the server. Make sure the firewall profile on the external nic don't block the traffic you want to let through (by default it is set to the public profile).

share|improve this answer
    
Thanks for your reply. I assigned IP to the ext NIC and assigned a default gateway. The internal NIC, as u advised, I gave only an IP without gateway. Then the default route was going to the correct gateway. Now, I can access the internet from this server but when this IP is pinged from outside, there is no reply and I also cannot access using Remote Desktop. Is there something I am missing? –  i.h4d35 Jan 4 '13 at 5:59
1  
Also, I have disabled the Windows Firewall for both connections. Is there some rule that still needs to be writted/enabled disabled in the Windows firewall? –  i.h4d35 Jan 4 '13 at 6:05
    
What ping reply do you get, "destination host unreachable" or "request timed out"? You have enabled remote dektop connections on the server, you can rdp from a computer connectec to the local network? –  Molotch Jan 4 '13 at 8:46
    
worked - the AV installed on the server was blocking the incoming ping requests. Thanks for your help. –  i.h4d35 Jan 18 '13 at 13:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.