Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have created a Standard user and disabled the "Switch User/Lock" from registry with the followings :

  1. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer [StartMenuLogOff=1]

  2. HKEY_LOCAL_MACHINE\SOFTWARE \Microsoft\Windows\CurrentVersion\Policies\System [HideFastUserSwitching=1]

  3. HKEY_LOCAL_MACHINE\SOFTWARE \Microsoft\Windows\CurrentVersion\Policies\System [DisableLockWorkstation=1]

These are working fine.

but still "log off" button enabled.

I tried this one HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced [StartMenuLogoff=1]

but no luck.

Please let me know how can I disable it.

Thanks, Laxmilal Menaria

share|improve this question

1 Answer 1

You can do this via Group Policy (local or global):

Configuration \ Administrative Templates \ Start Menu and Taskbar \ Remove Logoff on the Start Menu

share|improve this answer
    
Tried the same but no luck. –  LLM Jan 3 '13 at 11:21
    
Are you doing it from a local GPO? Or Global? Have you done a gpresult to see if the policy is being applied? –  cole Jan 3 '13 at 11:22
    
I have Cloud VM hosted on Amazon Ec2, accessing it using RDP and don't wan't to standrad user logoff them. I am trying using "Administrator' account. –  LLM Jan 3 '13 at 11:29
    
GPO: Local Group Policy KeyName: Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoLogoff Value: 1, 0, 0, 0 State: Enabled GPO: Local Group Policy KeyName: Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\StartMenuLogOff Value: 1, 0, 0, 0 State: Enabled –  LLM Jan 3 '13 at 11:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.