Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've just puppetted a virtual machine and from scratch (based on Centos 6.3 minimal). That install process does a variety of things, but one annoying side effect is that when the VM reboots, it automatically opens a tool called:

Text Mode Setup Utility 1.19.9    (c) 1999-200 Red Hat, Inc.

Is says "Choose a Tool" with options for "Authentication configuration", "Firewall configuration", "Keyboard configuration", "Network configuration". I don't think it serves a purpose as the VM is sufficiently well configured for what we need to use it for, but it's annoying that it doesn't restart to the normal login prompt.

Can anyone tell me how to stop this Text Mode Setup Utility running? Is it a missing configuration option or a spurious package I've installed?

--- Update 1 ---

Here's the output of chkconfig. It looks like firstboot is running. I didn't know what that is, but now I've read:

http://www.centos.org/docs/5/html/5.1/Deployment_Guide/s2-sysconfig-firewall.html

so I'll touch /etc/sysconfig/firstboot, which should stop it happening?

NetworkManager  0:off   1:off   2:on    3:on    4:on    5:on    6:off
auditd          0:off   1:off   2:on    3:on    4:on    5:on    6:off
avahi-daemon    0:off   1:off   2:off   3:on    4:on    5:on    6:off
cgconfig        0:off   1:off   2:off   3:off   4:off   5:off   6:off
cgred           0:off   1:off   2:off   3:off   4:off   5:off   6:off
crond           0:off   1:off   2:on    3:on    4:on    5:on    6:off
csf             0:off   1:off   2:on    3:on    4:on    5:on    6:off
dnsmasq         0:off   1:off   2:off   3:off   4:off   5:off   6:off
firstboot       0:off   1:off   2:off   3:on    4:off   5:on    6:off
haldaemon       0:off   1:off   2:off   3:on    4:on    5:on    6:off
httpd           0:off   1:off   2:off   3:off   4:off   5:off   6:off
ip6tables       0:off   1:off   2:on    3:on    4:on    5:on    6:off
iptables        0:off   1:off   2:on    3:on    4:on    5:on    6:off
lfd             0:off   1:off   2:on    3:on    4:on    5:on    6:off
lvm2-monitor    0:off   1:on    2:on    3:on    4:on    5:on    6:off
mdmonitor       0:off   1:off   2:on    3:on    4:on    5:on    6:off
memcached       0:off   1:off   2:on    3:on    4:on    5:on    6:off
messagebus      0:off   1:off   2:on    3:on    4:on    5:on    6:off
mysqld          0:off   1:off   2:on    3:on    4:on    5:on    6:off
netconsole      0:off   1:off   2:off   3:off   4:off   5:off   6:off
netfs           0:off   1:off   2:off   3:on    4:on    5:on    6:off
network         0:off   1:off   2:on    3:on    4:on    5:on    6:off
ntpd            0:off   1:off   2:on    3:on    4:on    5:on    6:off
ntpdate         0:off   1:off   2:off   3:off   4:off   5:off   6:off
postfix         0:off   1:off   2:on    3:on    4:on    5:on    6:off
puppet          0:off   1:off   2:off   3:off   4:off   5:off   6:off
rdisc           0:off   1:off   2:off   3:off   4:off   5:off   6:off
restorecond     0:off   1:off   2:off   3:off   4:off   5:off   6:off
rsyslog         0:off   1:off   2:on    3:on    4:on    5:on    6:off
saslauthd       0:off   1:off   2:off   3:off   4:off   5:off   6:off
spice-vdagentd  0:off   1:off   2:off   3:off   4:off   5:on    6:off
sshd            0:off   1:off   2:on    3:on    4:on    5:on    6:off
svnserve        0:off   1:off   2:off   3:off   4:off   5:off   6:off
udev-post       0:off   1:on    2:on    3:on    4:on    5:on    6:off
wdaemon         0:off   1:off   2:off   3:off   4:off   5:off   6:off
wpa_supplicant  0:off   1:off   2:off   3:off   4:off   5:off   6:off
zend-server     0:off   1:off   2:on    3:on    4:on    5:on    6:off

--- Update 2 ----

Alas no. I also tried editing to /etc/sysconfig/firstboot to include the line RUN_FIRSTBOOT = no, as described at http://forum.eltechsupport.com/operating-system/run-firstboot-on-linux/ but another reboot and the tool is still popping up. Can you tell me how to disable it? Also, might you cast an expert eye down the list of services running and tell me if there's anything else I shouldn't be running on a production webserver please?

--- Update 3 ---

Thanks. That worked a treat. Marking as answer:

sudo chkconfig firstboot off
share|improve this question
    
I think you can chkconfig firstboot off. –  ewwhite Jan 3 '13 at 17:07

1 Answer 1

up vote 1 down vote accepted

Can you show the output of chkconfig? How about your kickstart file? Is firstboot enabled?

Make sure you haven't activated the sys-unconfig functionality. This places a file in /.unconfigured which can start the setup tool you're referring to.

The name of the package that the utility belongs to is setuptool.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.