Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm getting the following errors when trying to do a proxy to an SSL backend server:

[Thu Jan 03 14:44:26 2013] [error] (502)Unknown error 502: proxy: pass request body failed to 192.168.1.10:8443 (192.168.1.10) [Thu Jan 03 14:44:26 2013] [error] [client 192.168.1.103] proxy: Error during SSL Handshake with remote server returned by /subsonic/ [Thu Jan 03 14:44:26 2013] [error] proxy: pass request body failed to 192.168.1.10:8443 (192.168.1.10) from 192.168.1.103 ()

I've got the following apache config setup:

<VirtualHost *:443>
ServerName home.zombor.net
DocumentRoot "/media/Drobo02/www/home.zombor.net/"

SSLEngine on
SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
SSLCertificateFile /etc/ssl/apache2/home.zombor.net.crt
SSLCertificateKeyFile /etc/ssl/apache2/home.zombor.net.key
SSLProxyEngine on
SSLVerifyClient None

<Directory "/media/Drobo02/www/home.zombor.net/">
    Options Indexes FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<IfModule mpm_peruser_module>
    ServerEnvironment apache apache
</IfModule>

# Proxy subsonic
ProxyRequests Off
ProxyPreserveHost Off
<Proxy *>
    Options FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    Allow from all
</Proxy>
ProxyPass /subsonic https://192.168.1.10:8443/subsonic
ProxyPassReverse /subsonic https://192.168.1.10:8443/subsonic

I also tried using localhost for the backend server, but I get the same error. It works fine when I proxy to a non-ssl backend, but I need this to be SSL because subsonic does not work correctly if the scheme is different.

share|improve this question
    
Apache is telling you that there was an error negotiating SSL with the back end server. So, what happens when you connect to the back end server with SSL manually? Is it configured correctly? –  bahamat Jan 3 '13 at 23:44
    
I can connect to the backend server fine. I get an SSL error for being a self signed cert, but that's why I put SSLVerifyClient None in my config. –  zombor Jan 4 '13 at 0:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.