Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to configure a new 5505 but I am having difficulties opening ports that allow traffic in from the outside. My setup is Comcast Business Modem (w/ single static IP) -> ASA (10.0.0.1) -> (dumb) Switch -> NAS (10.0.0.10). I am attemping to open port 5001 to the NAS. I am very new to IOS so I have mostly been working in ASDM. Not sure if I am overcomplicating this for myself or what but I am stuck.

My running config is -

ASA Version 8.2(5) 
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 10.0.0.10 MiniSrvr description MiniSrvr
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 10.0.0.1 255.255.255.0 
!
interface Vlan2
nameif outside
security-level 0
ip address 74.x.x.249 255.255.255.252 
!
ftp mode passive
object-group service Syno_HTTPS tcp
port-object eq 5001
object-group service DM_INLINE_TCP_1 tcp
group-object Syno_HTTPS
port-object eq https
access-list outside_access_in extended permit tcp any host MiniSrvr object-group DM_INLINE_TCP_1 
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 5001 MiniSrvr 5001 netmask 255.255.255.255 
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 74.x.x.250 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL 
http server enable
http 10.0.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh 10.0.0.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd dns 75.75.75.75 75.75.76.76
dhcpd lease 38600
!
dhcpd address 10.0.0.100-10.0.0.199 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
anyconnect-essentials
username xxx password XTTcBNvipbwHw4hk encrypted privilege 15
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map 
inspect ftp 
inspect h323 h225 
inspect h323 ras 
inspect rsh 
inspect rtsp 
inspect esmtp 
inspect sqlnet 
inspect skinny  
inspect sunrpc 
inspect xdmcp 
inspect sip  
inspect netbios 
inspect tftp 
inspect ip-options 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
Cryptochecksum:33ba890463db57b8ad5a2ecbf378b412
: end
share|improve this question
    
I see vlan2 being mapped to an ethernet interface, shouldn't I be seeing a similar vlan1 mapping? –  mdpc Jan 4 '13 at 0:40
    
What's tripping you up, exactly? Create a new rule, allowing port 5001 to 10.0.0.10. I'm really having trouble trying to imagine where you're having trouble doing this in the ASDM - it's a GUI. –  HopelessN00b Jan 4 '13 at 0:50
    
@mdpc vlan 1 is the default and all the other ports are on vlan 1. –  GerryEgan Jan 4 '13 at 10:26
add comment

3 Answers

You have a NAT rule mapping port 5001 to your NAS. You are missing the firewall rule for port 5001. Add the following and it will work:

access-list outside_access_in extended permit tcp any host MiniSrvr object-group Syno_HTTPS
share|improve this answer
add comment

On ASA 8.2 code, the destination on the ACE should be, in your case, the interface address, not the internal network object (if this was 8.3 code you'd have it right). Command for this would be:

access-list outside_access_in extended permit tcp any interface outside eq 5001

Your NAT entry looks correct, so that should fix it for you.

share|improve this answer
add comment

Just to clarify something for you ASA is not IOS, so that may be inhibiting your googlefoo abilities on this one.

Regarding the config you have there these are the significant lines in your config:

<--snip-->
object-group service Syno_HTTPS tcp
port-object eq 5001
object-group service DM_INLINE_TCP_1 tcp
group-object Syno_HTTPS
port-object eq https
access-list outside_access_in extended permit tcp any host MiniSrvr object-group DM_INLINE_TCP_1 
<--snip-->
static (inside,outside) tcp interface 5001 MiniSrvr 5001 netmask 255.255.255.255 
access-group outside_access_in in interface outside
<--snip-->

You have the correct NAT rule, but you need to add this line to your access list:

access-list outside_access_in extended permit tcp any host MiniSrvr object-group Syno_HTTPS
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.