Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a CentOS 6.3 machine currently running 2 virtualized CentOS 6.2 machines via KVM/QEMU/Libvirt. I'm trying to setup filesystem passthrough between the guests and the host. However the option is grayed out in the Virtualization Manager with the message "Not supported for this hypervisor/libvirt combination".

And in addition if I attempt to set it up using

virsh edit [VM name]

The VM throws an error on boot along the lines of "passthrough not supported by QEMU" (Sorry I don't have the exact error right now. I don't have access to the machine, will update next time I'm in front of it).

I can't seem to find a lot of information on this issue. Is there a compatibility issue between CentOS and filesystem passthrough?


share|improve this question
up vote 3 down vote accepted

Strange I was trying to do the same thing today as well. I don't think it's currently supported in the version of KVM that's included with CentOS 6.x.

% rpm -aq|grep kvm

I think this is the error you're referring to:

error is: Not supported for this hypervisor/libvirt combination (CentOS 6.3)

According to the libvirt documentation for the Domain XML format, filesystem is a supported command taking passthrough as an accessmode:

These links were helpful:

share|improve this answer
Yeah I've checked out all those links while I was trying to set it up. I've tried adding a filesystem block to the XML file like I said in my question, (you said a it a lot more eloquently than I did haha) but ran into an error booting up the VMs, again complaining that this version of QEMU doesn't support passthrough. – mm118 Jan 4 '13 at 5:46
Yeah I don't think it's supported as of yet. I'm not entirely sure if you can download a newer version of qemu/kvm and install it on CentOS 6.3 either. That may be an option. – slm Jan 4 '13 at 5:48
I've tried using newer versions of qemu/kvm but doesn't seem to work. Do you know of a workaround for this issue? – mm118 Jan 4 '13 at 23:55

Although you can't fix the problem itself (as you've mentioned), yes, there is a very easy workaround that will "setup filesystem pass-through between the guests and the host" or something that does more or less the same: a network share!!

That easy.

Export (share) a folder on your Host system, using any tool, nautilus or setting samba conf file yourself (usually /etc/samba/smb.conf). You can even have it secure by bound to the IP of the virtual network (virbr0 or so).

Then in your guest OS, open the network share either with nautilus or any other tool. You make a windows network (CIFS) on top of the virtual network. I hope it would do what you want.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.