Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to connect two machines via ttyS0

Here's what I did on the guest machines:

A:

  • Add to /etc/inittab:

    S0:2345:respawn:/sbin/mingetty ttyS0

  • Add to /etc/securetty:

    ttyS0

B:

  • Try to connect to A

    cu -l /dev/ttyS0

Here's what I did on the host machine:

mkfifo /tmp/serialbridge
qemu-system-x86_64 -hda A.qcow2 -net nic -net user -m 2048 -enable-kvm -cpu host -machine type=pc,accel=kvm -serial pipe:/tmp/serialbridge
qemu-system-x86_64 -hda B.qcow2 -net nic -net user -m 2048 -enable-kvm -cpu host -machine type=pc,accel=kvm -serial pipe:/tmp/serialbridge

I guess the paramter "-serial pipe:/tmp/serialbridge" is wrong. Any ideas how to fix that?

(Qemu is self-compiled from the latest Git tree.)

Result: cu doesn't show login, but rather seems stuck. The other machine seems to hang after login screen. Both run Debian Squeeze.

share|improve this question
    
did you add console=ttyS0 to the kernel opts in grub in the guests? – dyasny Jan 6 '13 at 6:49
    
No, adding console=ttyS0 didn't help. – user152476 Jan 8 '13 at 10:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.