Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a global rsnapshot config file for all machines that we backup. The global file has

ssh_args -p 123

The machine specific files include the global config file and tries to override the port:

include_conf    /etc/rsnapshot-common.conf
ssh_args    -p 456

This does not work, I get the error:

global ssh_args can only be set once, but is already set. Perhaps you wanted to use a per-backup-point ssh_args instead.

So it knows what I want to do, but it doesn't tell me how to do it! The man page doesn't mention any way of doing this either. How do I change the port after its been set globally?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

The rsnapshot man page seems to imply that you add the per-backup-point arguments as a comma separated list after the destination, the example they give is

backup /var/ localhost/ one_fs=1

This is the same as the other examples, but notice the fourth column. This is how you specify per-backup-point options to over-ride global settings. This extra parameter can take several options, separated by commas.

so I guess you would use

backup /var/ localhost/ ssh_args=-p456
share|improve this answer
    
Thanks! It looks like this is the syntax backup /var/ localhost/ ssh_args=-p456 –  Nick Jan 4 '13 at 20:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.